Wednesday, September 19, 2018

Multi-Topology Routing


In modern networks the need for differentiating certain types of traffic arise, i.e. to allow certain traffic classes to be treated differently and to be routed differently other than normal traffic
This need arise from the criticality of traffic passing through network which sometimes forces the network administrator to influence the pattern based on the needs
MTR (Multi-Topology Routing) gives the ability to network owners to perform service differentiation through class based forwarding
Before going further into details, what is the keyword topology means to start with? A Topology is defined as a set of routers and links for which a separate routes are calculated.
The entire network where the usual routes are calculated is known as the base topology. Any additional topology is knows as class specific topologies and they are a subset of the base topology. Each class specific topology handles a traffic and characterized by an independent set of NLRI (Network Layer Reachability Information) that is used to maintain separate RIB and FIB which gives the router the flexibility to perform route calculation and forwarding for each topology independently.


 
Intermediate System to Intermediate System is one of the dynamic routing protocols that support MTR
We will be using the below topology to demonstrate the feature




As can be seen from the above diagram, we have a core network consists of 5 routers, the networks of concern are the loopback 0 interface of R1 and the loopback 0 interface of R5
The source of packets will be loopback 0 interface of R1 and the destination of concern will be loopback 0 interface of R5
All routers will be participating in the same area (49.0001) and all routers will be in the level 2 domain (our focus is MTR not ISIS functionality and circuit types)



 
Note: all link IP addressing scheme will be using the 192.168.XY.0/24 (where X is the source router and Y is the destination router), as well, only loopback interfaces are to be configured on the target routers: R1 and R5
Configuration
R1:
router isis 1
 net 49.0001.0000.0000.0001.00
 is-type level-2-only

interface {}
 ip router isis 1


R2:
router isis 1
 net 49.0001.0000.0000.0002.00
 is-type level-2-only

interface {}
 ip router isis 1

R3:
router isis 1
 net 49.0001.0000.0000.0003.00
 is-type level-2-only

interface {}
 ip router isis 1
 


R4:
router isis 1
 net 49.0001.0000.0000.0004.00
 is-type level-2-only

interface {}
 ip router isis 1

R5:
router isis 1
 net 49.0001.0000.0000.0005.00
 is-type level-2-only

interface {}
 ip router isis 1

As can be seen from the below diagram, there are two equal paths to reach from R1 loopback 0 interface and R5 loopback 0 interface



The first route is through the path: R1 – R3 – R5 and the second one is through the path: R1 – R3 – R5
Note: There is another path which is through R1 – R2 – R4 – R5 but will be out of focus in this document
R1#sh ip route isis

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      5.0.0.0/32 is subnetted, 1 subnets
i L2     5.5.5.5 [115/30] via 192.168.13.3, 00:04:32, FastEthernet1/0
                       [115/30] via 192.168.12.2, 00:04:32, FastEthernet2/0
i L2  192.168.24.0/24 [115/20] via 192.168.12.2, 00:05:38, FastEthernet2/0
i L2  192.168.25.0/24 [115/20] via 192.168.12.2, 00:05:38, FastEthernet2/0
i L2  192.168.35.0/24 [115/20] via 192.168.13.3, 00:05:25, FastEthernet1/0
i L2  192.168.45.0/24 [115/30] via 192.168.13.3, 00:01:04, FastEthernet1/0
                                    [115/30] via 192.168.12.2, 00:01:04, FastEthernet2/0

R1#sh ip route 5.5.5.5
Routing entry for 5.5.5.5/32
  Known via "isis", distance 115, metric 30, type level-2
  Redistributing via isis 1
  Last update from 192.168.13.3 on FastEthernet1/0, 00:11:48 ago
  Routing Descriptor Blocks:
    192.168.13.3, from 5.5.5.5, 00:11:48 ago, via FastEthernet1/0
      Route metric is 30, traffic share count is 1
  * 192.168.12.2, from 5.5.5.5, 00:11:48 ago, via FastEthernet2/0
      Route metric is 30, traffic share count is 1

R1#traceroute 5.5.5.5 source loopback 0 numeric

Type escape sequence to abort.
Tracing the route to 5.5.5.5

  1 192.168.12.2 48 msec
    192.168.13.3 36 msec
    192.168.12.2 16 msec
  2 192.168.35.5 32 msec
    192.168.25.5 40 msec

The demonstration example will take two DSCP values into consideration (DSCP 46 which is the critical traffic usually representing voice and video traffic will follow the path R1 – R3 – R5 and it will be part of the topology called CRITICAL_TOP
The second topology for which the DSCP 32 marked traffic usually representing real time traffic denoted as telepresence in the coming diagram will be handled by the so called topology NONCRITICAL_TOP





As depicted in the topology , we will influence traffic marked with DSCP46 to use the path R1 – R3 – R5 and the traffic marked with DSCP32 to use the path R1 – R2 – R4 – R5
Each traffic pattern will use its own topology which means independent forwarding decision and separated RIB, FIB as will be demonstrated later
The word class has been mentioned more than once previously, which means we have to mark our traffic as it is coming inside our network, how we are going to classify? Exactly: MQC
But first let us create our new topologies apart from the original one: Base topology
R1#show topology
Topology                   Address      Family        Associated VRF                  State
base                            ipv4            default                                                 UP

Topologies Definition:

global-address-family ipv4
 topology CRITICAL_TOP
  forward-base
 topology NONCRITICAL_TOP
  forward-base

R1#sh topology
Topology                        Address Family  Associated VRF                  State
base                            ipv4            default                         UP

CRITICAL_TOP                    ipv4            default                         UP

NONCRITICAL_TOP                 ipv4            default                         UP
MTR Traffic Classification:

class-map match-any CRITICAL_CLASS
 match ip dscp 46

class-map match-any NONCRITICAL_CLASS
 match ip dscp 32

policy-map type class-routing ipv4 unicast POLICY
 class CRITICAL_CLASS
  select-topology CRITICAL_TOP

class NONCRITICAL_CLASS
  select-topology NONCRITICAL_TOP

global-address-family ipv4
 topology CRITICAL_TOP
  forward-base

 topology NONCRITICAL_TOP
  forward-base
service-policy type class-routing POLICY

Note: Before proceeding, when trying to trace route from the router to any destination, you will not see the topology option

R1#traceroute ?
  WORD       Trace route to destination address or hostname
  appletalk  AppleTalk Trace
  clns       ISO CLNS Trace
  ip         IP Trace
  ipv6       IPv6 Trace
  ipx        IPX Trace
  mpls       MPLS LSP Trace
  oldvines   Vines Trace (Cisco)
  vines      Vines Trace (Banyan)

After defining the topologies (regardless of the number) , you will be able to see it and execute the command based on its parameters

R1#traceroute ?
  WORD       Trace route to destination address or hostname
  appletalk  AppleTalk Trace
  clns       ISO CLNS Trace
  ip         IP Trace
  ipv6       IPv6 Trace
  ipx        IPX Trace
  mpls       MPLS LSP Trace
  oldvines   Vines Trace (Cisco)
  topology   Select the topology
  vines      Vines Trace (Banyan)

As well, we now can execute many commands related to a specific topology and one the command of concern is to view the RIB using the most well know command show ip route associated with the target topology:

R1#sh ip route topology CRITICAL_TOP

Routing Table: CRITICAL_TOP
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
C        1.1.1.1 is directly connected, Loopback0
      192.168.12.0/32 is subnetted, 1 subnets
L        192.168.12.1 is directly connected, FastEthernet2/0
      192.168.13.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.13.0/24 is directly connected, FastEthernet1/0
L        192.168.13.1/32 is directly connected, FastEthernet1/0

As can be seen from the above output, no ISIS routes have been installed yet. The reason for is that we still did not integrate our new defined topologies to our IGP: ISIS. This will enable the metrics for the defined topologies to be sent via LSPs

To accomplish this, we need to access the router isis configuration mode and access the respective address-family: IPv4 (knowing that MTR is still not support for the IPv6 address-family

R1(config)#router isis 1
R1(config-router)#address-family ipv4
% Must enable wide metrics first

As can be seen from the above output, we have to change the metric-style to wide in order to successfully activate the feature (for more details about the isis metric-style, please check the below link)


router isis 1
 metric-style wide
address-family ipv4
  topology CRITICAL_TOP tid 30
  topology NONCRITICAL_TOP tid 40

Each topology must be assigned a topology ID (tid) from a predefined range:

R1(config-router-af)#topology CRITICAL_TOP tid ?
  <5-4095>  Routing topology tid

Next, what have to be done is to enable the topology instances on a per-interface basis (we will follow the third diagram which clearly shows how the DSCP46 marked traffic is treated as well the DSCP32 marked traffic)

R1:
interface Loopback0
topology ipv4 unicast CRITICAL_TOP
topology ipv4 unicast NONCRITICAL_TOP

interface FastEthernet1/0
topology ipv4 unicast CRITICAL_TOP
  isis metric 20

interface FastEthernet2/0
topology ipv4 unicast NONCRITICAL_TOP
  isis metric 30

R2:
interface FastEthernet1/0
topology ipv4 unicast NONCRITICAL_TOP
  isis metric 30

interface FastEthernet3/0
topology ipv4 unicast NONCRITICAL_TOP
  isis metric 30

R3:
interface FastEthernet1/0
topology ipv4 unicast CRITICAL_TOP
  isis metric 20

interface FastEthernet2/0
 topology ipv4 unicast CRITICAL_TOP
  isis metric 20

R4:
interface FastEthernet1/0
topology ipv4 unicast NONCRITICAL_TOP
  isis metric 30

interface FastEthernet2/0
topology ipv4 unicast NONCRITICAL_TOP
  isis metric 30

R5:
interface Loopback0
topology ipv4 unicast CRITICAL_TOP
topology ipv4 unicast NONCRITICAL_TOP

interface FastEthernet1/0
topology ipv4 unicast CRITICAL_TOP
  isis metric 20

interface FastEthernet3/0
topology ipv4 unicast NONCRITICAL_TOP
  isis metric 30

As we are concerned about the loopback interfaces for both R1 and R5 and the traffic of interest is sourced from R1 loopback 0 interface to R5 loopback 0 interface for different types of traffic using the defined topologies , both topologies (in our example) have to be enabled on these interfaces

Now, before doing the respective tests to ensure the proper flow of data as defined, let us check the database of our routing protocol

R1#show isis database detail

IS-IS Level-2 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
R1.00-00            * 0x00000089   0xF481        1160              0/0/0
  Area Address: 49.0001
  Topology:     IPv4 (0x0)
                TID 30 (0x1E)
                TID 40 (0x28)
  NLPID:        0xCC
  Hostname: R1
  IP Address:   1.1.1.1
  Metric: 10         IS-Extended R2.01
  Metric: 10         IS-Extended R3.01
  Metric: 20         IS (MT-TID 30) R3.01
  Metric: 30         IS (MT-TID 40) R2.01
  Metric: 10         IP 1.1.1.1/32
  Metric: 10         IP 192.168.12.0/24
  Metric: 10         IP 192.168.13.0/24
  Metric: 10         IP (MT-TID 30) 1.1.1.1/32
  Metric: 20         IP (MT-TID 30) 192.168.13.0/24
  Metric: 10         IP (MT-TID 40) 1.1.1.1/32
  Metric: 30         IP (MT-TID 40) 192.168.12.0/24
R2.00-00              0x0000008A   0xC1ED        1181              0/0/0
  Area Address: 49.0001
  Topology:     IPv4 (0x0)
                TID 30 (0x1E)
                TID 40 (0x28)
  NLPID:        0xCC
  Hostname: R2
  IP Address:   192.168.24.2
  Metric: 10         IS-Extended R2.01
  Metric: 10         IS-Extended R4.01
  Metric: 10         IS-Extended R5.03
  Metric: 30         IS (MT-TID 40) R2.01
  Metric: 30         IS (MT-TID 40) R4.01
  Metric: 10         IP 192.168.12.0/24
  Metric: 10         IP 192.168.24.0/24
  Metric: 10         IP 192.168.25.0/24
  Metric: 30         IP (MT-TID 40) 192.168.12.0/24
  Metric: 30         IP (MT-TID 40) 192.168.24.0/24
R2.01-00              0x00000084   0x77CE        308               0/0/0
  Metric: 0          IS-Extended R2.00
  Metric: 0          IS-Extended R1.00
R3.00-00              0x00000088   0xA8D8        606               0/0/0
  Area Address: 49.0001
  Topology:     IPv4 (0x0)
                TID 30 (0x1E)
                TID 40 (0x28)
  NLPID:        0xCC
  Hostname: R3
  IP Address:   192.168.35.3
  Metric: 10         IS-Extended R3.01
  Metric: 10         IS-Extended R5.02
  Metric: 20         IS (MT-TID 30) R3.01
  Metric: 20         IS (MT-TID 30) R5.02
  Metric: 10         IP 192.168.13.0/24
  Metric: 10         IP 192.168.35.0/24
  Metric: 20         IP (MT-TID 30) 192.168.13.0/24
  Metric: 20         IP (MT-TID 30) 192.168.35.0/24
R3.01-00              0x00000085   0x76CC        947               0/0/0
  Metric: 0          IS-Extended R3.00
  Metric: 0          IS-Extended R1.00
R4.00-00              0x00000089   0xD739        647               0/0/0
  Area Address: 49.0001
  Topology:     IPv4 (0x0)
                TID 30 (0x1E)
                TID 40 (0x28)
  NLPID:        0xCC
  Hostname: R4
  IP Address:   192.168.45.4
  Metric: 10         IS-Extended R4.01
  Metric: 10         IS-Extended R5.04
  Metric: 30         IS (MT-TID 40) R4.01
  Metric: 30         IS (MT-TID 40) R5.04
  Metric: 10         IP 192.168.24.0/24
  Metric: 10         IP 192.168.45.0/24
  Metric: 30         IP (MT-TID 40) 192.168.24.0/24
  Metric: 30         IP (MT-TID 40) 192.168.45.0/24
R4.01-00              0x00000084   0x8DB3        648               0/0/0
  Metric: 0          IS-Extended R4.00
  Metric: 0          IS-Extended R2.00
R5.00-00              0x00000089   0x11D2        333               0/0/0
  Area Address: 49.0001
  Topology:     IPv4 (0x0)
                TID 30 (0x1E)
                TID 40 (0x28)
  NLPID:        0xCC
  Hostname: R5
  IP Address:   5.5.5.5
  Metric: 10         IS-Extended R5.04
  Metric: 10         IS-Extended R5.03
  Metric: 10         IS-Extended R5.02
  Metric: 20         IS (MT-TID 30) R5.02
  Metric: 30         IS (MT-TID 40) R5.04
  Metric: 10         IP 5.5.5.5/32
  Metric: 10         IP 192.168.25.0/24
  Metric: 10         IP 192.168.35.0/24
  Metric: 10         IP 192.168.45.0/24
  Metric: 10         IP (MT-TID 30) 5.5.5.5/32
  Metric: 20         IP (MT-TID 30) 192.168.35.0/24
  Metric: 10         IP (MT-TID 40) 5.5.5.5/32
  Metric: 30         IP (MT-TID 40) 192.168.45.0/24
R5.02-00              0x00000086   0x97A3        1004              0/0/0
  Metric: 0          IS-Extended R5.00
  Metric: 0          IS-Extended R3.00
R5.03-00              0x00000085   0x7EBD        1127              0/0/0
  Metric: 0          IS-Extended R5.00
  Metric: 0          IS-Extended R2.00
R5.04-00              0x00000083   0xA397        445               0/0/0
  Metric: 0          IS-Extended R5.00
  Metric: 0          IS-Extended R4.00

As can be seen, all parameters defined (such as tid and metric are shown in this output), as well, we can be more precise in choosing the topology of concern

R1#show isis database detail topology CRITICAL_TOP

IS-IS Level-2 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
R1.00-00            * 0x00000089   0xF481        1070              0/0/0
  Area Address: 49.0001
  Topology:     TID 30 (0x1E)
  NLPID:        0xCC
  Hostname: R1
  IP Address:   1.1.1.1
  Metric: 20         IS (MT-TID 30) R3.01
  Metric: 10         IP (MT-TID 30) 1.1.1.1/32
  Metric: 20         IP (MT-TID 30) 192.168.13.0/24
R2.00-00              0x0000008A   0xC1ED        1092              0/0/0
  Area Address: 49.0001
  Topology:     TID 30 (0x1E)
  NLPID:        0xCC
  Hostname: R2
  IP Address:   192.168.24.2
R2.01-00              0x00000085   0x75CF        1117              0/0/0
R3.00-00              0x00000088   0xA8D8        517               0/0/0
  Area Address: 49.0001
  Topology:     TID 30 (0x1E)
  NLPID:        0xCC
  Hostname: R3
  IP Address:   192.168.35.3
  Metric: 20         IS (MT-TID 30) R3.01
  Metric: 20         IS (MT-TID 30) R5.02
  Metric: 20         IP (MT-TID 30) 192.168.13.0/24
  Metric: 20         IP (MT-TID 30) 192.168.35.0/24
R3.01-00              0x00000085   0x76CC        858               0/0/0
R4.00-00              0x00000089   0xD739        558               0/0/0
  Area Address: 49.0001
  Topology:     TID 30 (0x1E)
  NLPID:        0xCC
  Hostname: R4
  IP Address:   192.168.45.4
R4.01-00              0x00000084   0x8DB3        559               0/0/0
R5.00-00              0x0000008A   0x0FD3        1119              0/0/0
  Area Address: 49.0001
  Topology:     TID 30 (0x1E)
  NLPID:        0xCC
  Hostname: R5
  IP Address:   5.5.5.5
  Metric: 20         IS (MT-TID 30) R5.02
  Metric: 10         IP (MT-TID 30) 5.5.5.5/32
  Metric: 20         IP (MT-TID 30) 192.168.35.0/24
R5.02-00              0x00000086   0x97A3        914               0/0/0
R5.03-00              0x00000085   0x7EBD        1036              0/0/0
R5.04-00              0x00000083   0xA397        355               0/0/0

Let us check the RIB for a specific topology compared to the global routing table:

R1#   sh ip route topology CRITICAL_TOP

Routing Table: CRITICAL_TOP
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
C        1.1.1.1 is directly connected, Loopback0
      5.0.0.0/32 is subnetted, 1 subnets
i L2     5.5.5.5 [115/50] via 192.168.13.3, 1d02h, FastEthernet1/0
      192.168.12.0/32 is subnetted, 1 subnets
L        192.168.12.1 is directly connected, FastEthernet2/0
      192.168.13.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.13.0/24 is directly connected, FastEthernet1/0
L        192.168.13.1/32 is directly connected, FastEthernet1/0
i L2  192.168.35.0/24 [115/40] via 192.168.13.3, 1d02h, FastEthernet1/0

R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
C        1.1.1.1 is directly connected, Loopback0
      5.0.0.0/32 is subnetted, 1 subnets
i L2     5.5.5.5 [115/30] via 192.168.13.3, 1d02h, FastEthernet1/0
                 [115/30] via 192.168.12.2, 1d02h, FastEthernet2/0
      192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.12.0/24 is directly connected, FastEthernet2/0
L        192.168.12.1/32 is directly connected, FastEthernet2/0
      192.168.13.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.13.0/24 is directly connected, FastEthernet1/0
L        192.168.13.1/32 is directly connected, FastEthernet1/0
i L2  192.168.24.0/24 [115/20] via 192.168.12.2, 1d02h, FastEthernet2/0
i L2  192.168.25.0/24 [115/20] via 192.168.12.2, 1d02h, FastEthernet2/0
i L2  192.168.35.0/24 [115/20] via 192.168.13.3, 1d02h, FastEthernet1/0
i L2  192.168.45.0/24 [115/30] via 192.168.13.3, 1d02h, FastEthernet1/0
                      [115/30] via 192.168.12.2, 1d02h, FastEthernet2/0

R1#show ip route topology CRITICAL_TOP 5.5.5.5

Routing Table: CRITICAL_TOP
Routing entry for 5.5.5.5/32
  Known via "isis", distance 115, metric 50, type level-2
  Redistributing via isis 1
  Last update from 192.168.13.3 on FastEthernet1/0, 1d02h ago
  Routing Descriptor Blocks:
  * 192.168.13.3, from 5.5.5.5, 1d02h ago, via FastEthernet1/0
      Route metric is 50, traffic share count is 1

R1#show ip route topology NONCRITICAL_TOP 5.5.5.5

Routing Table: NONCRITICAL_TOP
Routing entry for 5.5.5.5/32
  Known via "isis", distance 115, metric 100, type level-2
  Redistributing via isis 1
  Last update from 192.168.12.2 on FastEthernet2/0, 1d02h ago
  Routing Descriptor Blocks:
  * 192.168.12.2, from 5.5.5.5, 1d02h ago, via FastEthernet2/0
      Route metric is 100, traffic share count is 1

Now, let us examine the traffic flow for both DSCP values

R1#traceroute
Protocol [ip]:
Target IP address: 5.5.5.5
Source address: 1.1.1.1
DSCP Value [0]: 46
Numeric display [n]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Type escape sequence to abort.
Tracing the route to 5.5.5.5

  1 192.168.13.3 16 msec 16 msec 20 msec
  2 192.168.35.5 40 msec 20 msec *

R1#traceroute
Protocol [ip]:
Target IP address: 5.5.5.5
Source address: 1.1.1.1
DSCP Value [0]: 32
Numeric display [n]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Type escape sequence to abort.
Tracing the route to 5.5.5.5

  1 192.168.12.2 24 msec 12 msec 8 msec
  2 192.168.24.4 56 msec 28 msec 20 msec
  3 192.168.45.5 64 msec 56 msec *

R1#traceroute
Protocol [ip]:
Target IP address: 5.5.5.5
Source address: 1.1.1.1
DSCP Value [0]:
Numeric display [n]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Type escape sequence to abort.
Tracing the route to 5.5.5.5

  1 192.168.12.2 24 msec
    192.168.13.3 12 msec
    192.168.12.2 16 msec
  2 192.168.35.5 28 msec
    192.168.25.5 36 msec
    192.168.35.5 32 msec

And all is working as expected and packets are flowing through the determined paths

Design considerations:

When trying to apply this feature, several aspects to be take into consideration (rather than the hardware) such as:

·         Only IPv4 address-family traffic is supported (Multicast as well, IPv6 not)
·         Many databases do exist now as we are creating multiple topologies as well as RIB and FIB tables which could affect the scalability and stability of network in case the devices already in low profile in respect to memory and CPU
·         Adaptability is in place when using such a feature as it allow the administrator to manipulate traffic as needed (utilizing the links effectively)
·         No need for MPLS to be enabled in the network (when enabled, some other features could be deployed such as MPLS TE)
·         Redundancy can be achieved for traffic as topology could be used for some traffic and another topology could be used as a backup for the same traffic

Brian Storming:

From: Network admin
To: Consultant

Dear
Hope this finds you well

I have decided to deploy MTR within my ISIS backbone, and I have made up my mind to classify three types of traffic: Voice, TP and Scavenger
As well, I have chosen the paths that will carry the respective types of traffic as depicted in the network diagram
What I am confused about is which interfaces to be enabled for which topology?

Waiting your feedback

Thanks

BR,
Network Admin