Issue
The
goal is to achieve connectivity between R2 loopback 0 interface and R3 loopback
0 interface.
At
a first glance, the sub interface on R1 should be a multipoint sub interface as
the entire serial connections share the same subnet.
Configuration
R1#sh
run int s0/0
interface
Serial0/0
no ip address
encapsulation frame-relay
clock rate 64000
no frame-relay inverse-arp
R1#sh
run int s0/0.1
interface
Serial0/0.1 multipoint
ip address 192.168.123.1 255.255.255.0
snmp
trap link-status
frame-relay map ip 192.168.123.2 102 broadcast
frame-relay map ip 192.168.123.3 103 broadcast
R1#sh
run | sec router eigrp
router
eigrp 10
network 1.1.1.1 0.0.0.0
network 192.168.123.1 0.0.0.0
no auto-summary
R2#sh
run int s0/0
interface
Serial0/0
ip address 192.168.123.2 255.255.255.0
encapsulation frame-relay
clock rate 64000
frame-relay map ip 192.168.123.1 201 broadcast
frame-relay map ip 192.168.123.3 201 broadcast
no frame-relay inverse-arp
R2#sh
run | sec router eigrp
router
eigrp 10
network 2.2.2.2 0.0.0.0
network 192.168.123.2 0.0.0.0
no auto-summary
R3#sh
run int s0/0
interface
Serial0/0
ip address 192.168.123.3 255.255.255.0
encapsulation frame-relay
clock rate 64000
frame-relay map ip 192.168.123.1 301 broadcast
frame-relay map ip 192.168.123.2 301 broadcast
no frame-relay inverse-arp
end
R3#sh
run | sec router eigrp
router
eigrp 10
network 3.3.3.3 0.0.0.0
network 192.168.123.3 0.0.0.0
no auto-summary
Verification
R1#sh
frame-relay map
Serial0/0.1
(up): ip 192.168.123.2 dlci 102(0x66,0x1860), static,
broadcast,
CISCO, status defined, active
Serial0/0.1
(up): ip 192.168.123.3 dlci 103(0x67,0x1870), static,
broadcast,
CISCO, status defined, active
R1#ping
192.168.123.2
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 192.168.123.2, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R1#ping
192.168.123.3
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 192.168.123.3, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R1#sh
ip eigrp neighbors
IP-EIGRP
neighbors for process 10
H Address Interface Hold Uptime SRTT
RTO Q Seq
(sec) (ms) Cnt Num
1 192.168.123.3 Se0/0.1 137 20:24:13 22
200 0 12
0 192.168.123.2 Se0/0.1 134 20:25:14 278 1668 0 12
R1#sh
ip route eigrp
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/2297856] via 192.168.123.2,
20:25:15, Serial0/0.1
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/2297856] via 192.168.123.3,
20:24:14, Serial0/0.1
R1#ping
2.2.2.2
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R1#ping
3.3.3.3
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
R2#sh
frame-relay map
Serial0/0
(up): ip 192.168.123.1 dlci 201(0xC9,0x3090), static,
broadcast,
CISCO, status defined, active
R2#ping
192.168.123.1
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 192.168.123.1, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R2#sh
ip route eigrp
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/2297856] via 192.168.123.1,
20:07:24, Serial0/0
R3#sh
frame-relay map
Serial0/0
(up): ip 192.168.123.1 dlci 301(0x12D,0x48D0), static,
broadcast,
CISCO, status defined, active
R3#ping
192.168.123.1
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 192.168.123.1, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
R3#sh
ip rou
R3#sh
ip route eig
R3#sh
ip route eigrp
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/2297856] via 192.168.123.1,
20:25:06, Serial0/0
Now
, as we can see that R2 can’t see R3’s loopback 0 interface in it’s routing
table
R2#ping
3.3.3.3
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
.....
Success
rate is 0 percent (0/5)
As
known , that split horizon when configuring frame relay on the physical
interface is disabled , but we are using multipoint sub interface , so split-horizon
must be disabled on that sub interaface
R1(config)#int
s0/0.1
R1(config-subif)#no
ip split-horizon eigrp 10
Let
us check now the routing tables
R2#sh
ip route eigrp
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/2297856] via 192.168.123.1,
20:08:11, Serial0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/2809856] via 192.168.123.1,
00:00:12, Serial0/0
R3#sh
ip route eigrp
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/2297856] via 192.168.123.1,
20:25:47, Serial0/0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/2809856] via 192.168.123.1,
00:00:21, Serial0/0
R3#ping
2.2.2.2
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
.....
Success
rate is 0 percent (0/5)
Still
no ping , because no layer 3 ro later 2 mapping exit on R2 for R3 interface and
vice versa , so
R2(config)#int
s0/0
R2(config-if)#frame-relay
map ip 192.168.123.3 201
R3(config)#int
s0/0
R3(config-if)#frame-relay
map ip 192.168.123.2 301
Note
: there is no need for the keyword broadcast when communicating between spokes
R2#ping
3.3.3.3 source loopback 0
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
Packet
sent with a source address of 2.2.2.2
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R3#ping
2.2.2.2 source loopback 0
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
Packet
sent with a source address of 3.3.3.3
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
No comments:
Post a Comment