Issue
We will configure IPv6 addressing between
PEs and CEs and transport over the IPv4 MPLS backbone, i.e. 6VPE and eBGP will
be the PE-CE routing protocol
Configuration
For
the basic configuration of the L3 MPLS VPN please refer to http://eng-mssk.blogspot.com/2012/10/mpls-l3-vpn-ipv6-6pe.html
We
will list current configuration of our elements
CE1
CE1#sh
run int f1/0
interface
FastEthernet1/0
ip address 192.1.12.1 255.255.255.0
duplex full
speed 100
ipv6 address 2001:DB8:12::1/64
CE1#sh
run int lo0
interface
Loopback0
ip address 1.1.1.1 255.255.255.255
ipv6 address 2001:DB8::1/128
ipv6
ospf 1 area 0
PE1
PE1#sh
run int f1/0
interface
FastEthernet1/0
vrf forwarding MSSK
ip address 192.1.12.2 255.255.255.0
duplex full
speed 100
ipv6 address 2001:DB8:12::2/64
PE1#sh
run int f1/1
interface
FastEthernet1/1
ip address 192.1.23.2 255.255.255.0
ip ospf 1 area 0
duplex full
speed 100
mpls ip
PE1#sh
run int lo0
interface
Loopback0
ip address 2.2.2.2 255.255.255.255
ip ospf 1 area 0
ipv6 address 2001:DB8::2/128
PE1#s
run | sec vrf def
vrf
definition MSSK
rd 100:1
route-target export 100:1
route-target import 100:1
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
P
P#sh
run int f1/0
interface
FastEthernet1/0
ip address 192.1.23.3 255.255.255.0
ip ospf 1 area 0
duplex full
speed 100
mpls ip
P#sh
run int f1/1
interface
FastEthernet1/1
ip address 192.1.34.3 255.255.255.0
ip ospf 1 area 0
duplex full
speed 100
mpls ip
P#sh
run int lo0
interface
Loopback0
ip address 3.3.3.3 255.255.255.255
ip ospf 1 area 0
end
PE2
PE2#sh
run int f1/0
interface
FastEthernet1/0
ip address 192.1.34.4 255.255.255.0
ip ospf 1 area 0
duplex full
speed 100
mpls ip
PE2#sh
run int f1/1
interface
FastEthernet1/1
vrf forwarding MSSK
ip address 192.1.45.4 255.255.255.0
duplex full
speed 100
ipv6 address 2001:DB8:45::4/64
PE2#sh
run int lo0
interface
Loopback0
ip address 4.4.4.4 255.255.255.255
ip ospf 1 area 0
ipv6 address 2001:DB8::4/128
ipv6 nd ra mtu suppress
PE1#s
run | sec vrf def
vrf
definition MSSK
rd 100:1
route-target export 100:1
route-target import 100:1
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
CE2
CE2#sh
run int f1/0
interface
FastEthernet1/0
ip address 192.1.45.5 255.255.255.0
duplex full
speed 100
ipv6 address 2001:DB8:45::5/64
CE2#sh
run int lo0
interface
Loopback0
ip address 5.5.5.5 255.255.255.255
ipv6 address 2001:DB8::5/128
ipv6 nd ra mtu suppress
Now,
we have established eBGP sessions between CE1, PE1 and CE2, PE2 and we
advertised CEs loopbacks
CE1#sh
run | sec router bgp
router
bgp 1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:DB8:12::2 remote-as 100
!
address-family ipv6
neighbor 2001:DB8:12::2 activate
network 2001:DB8::1/128
exit-address-family
PE1#sh
run | sec router bgp
router
bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
!
address-family vpnv6
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community both
exit-address-family
!
address-family ipv6 vrf MSSK
neighbor 2001:DB8:12::1 remote-as 1
neighbor 2001:DB8:12::1 activate
redistribute bgp 1
no synchronization
exit-address-family
CE2#sh
run | sec router bgp
router
bgp 5
no synchronization
bgp log-neighbor-changes
neighbor 2001:DB8:45::4 remote-as 100
no neighbor 2001:DB8:45::4 activate
no auto-summary
!
address-family ipv6
neighbor 2001:DB8:45::4 activate
network 2001:DB8::5/128
exit-address-family
PE2#sh
run | sec router bgp
router
bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
!
address-family vpnv6
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv6 vrf MSSK
neighbor 2001:DB8:45::5 remote-as 5
neighbor 2001:DB8:45::5 activate
redistribute bgp 5
no synchronization
exit-address-family
Verification
CE1#sh
bgp ipv6 unicast summary
BGP
router identifier 1.1.1.1, local AS number 1
BGP
table version is 3, main routing table version 3
2
network entries using 312 bytes of memory
2
path entries using 152 bytes of memory
3/2
BGP path/bestpath attribute entries using 444 bytes of memory
1
BGP AS-PATH entries using 24 bytes of memory
0
BGP route-map cache entries using 0 bytes of memory
0
BGP filter-list cache entries using 0 bytes of memory
Bitfield
cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP
using 964 total bytes of memory
BGP
activity 2/0 prefixes, 2/0 paths, scan interval 60 secs
Neighbor V
AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2001:DB8:12::2 4
100 2862 2863
3 0 0 1d23h 1
CE1#sh
bgp ipv6 unicast
BGP
table version is 3, local router ID is 1.1.1.1
Status
codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin
codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>
2001:DB8::1/128 :: 0 32768 i
*>
2001:DB8::5/128 2001:DB8:12::2 0 100 5 i
CE1#sh
bgp ipv6 unicast neighbors 2001:DB8:12::2 advertised-routes
BGP
table version is 3, local router ID is 1.1.1.1
Status
codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin
codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>
2001:DB8::1/128 :: 0 32768 i
Total
number of prefixes 1
CE1#sh
bgp ipv6 unicast neighbors 2001:DB8:12::2 routes
BGP
table version is 3, local router ID is 1.1.1.1
Status
codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin
codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>
2001:DB8::5/128 2001:DB8:12::2 0 100 5 i
Total
number of prefixes 1
CE2#sh
bgp ipv6 unicast summary
BGP
router identifier 5.5.5.5, local AS number 5
BGP
table version is 4, main routing table version 4
2
network entries using 312 bytes of memory
2
path entries using 152 bytes of memory
3/2
BGP path/bestpath attribute entries using 444 bytes of memory
1
BGP AS-PATH entries using 24 bytes of memory
0
BGP route-map cache entries using 0 bytes of memory
0
BGP filter-list cache entries using 0 bytes of memory
Bitfield
cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP
using 964 total bytes of memory
BGP
activity 2/0 prefixes, 2/0 paths, scan interval 60 secs
Neighbor V
AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2001:DB8:45::4 4
100 2471 2471
4 0 0 1d17h 1
CE2#sh
bgp ipv6 unicast
BGP
table version is 4, local router ID is 5.5.5.5
Status
codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin
codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>
2001:DB8::1/128 2001:DB8:45::4 0 100 1 i
*>
2001:DB8::5/128 :: 0 32768 i
CE2#sh
bgp ipv6 unicast neighbors 2001:DB8:45::4 advertised-routes
BGP
table version is 4, local router ID is 5.5.5.5
Status
codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin
codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>
2001:DB8::5/128 :: 0 32768 i
Total
number of prefixes 1
CE2#sh
bgp ipv6 unicast neighbors 2001:DB8:45::4 routes
BGP
table version is 4, local router ID is 5.5.5.5
Status
codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin
codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>
2001:DB8::1/128 2001:DB8:45::4 0 100 1 i
Total
number of prefixes 1
PE1#sh
bgp vpnv6 unicast vrf MSSK summary
BGP
router identifier 2.2.2.2, local AS number 100
BGP
table version is 4, main routing table version 4
2
network entries using 360 bytes of memory
2
path entries using 192 bytes of memory
6/2
BGP path/bestpath attribute entries using 888 bytes of memory
2
BGP AS-PATH entries using 48 bytes of memory
1
BGP extended community entries using 24 bytes of memory
0
BGP route-map cache entries using 0 bytes of memory
0
BGP filter-list cache entries using 0 bytes of memory
Bitfield
cache entries: current 2 (at peak 2) using 64 bytes of memory
BGP
using 1576 total bytes of memory
BGP
activity 6/0 prefixes, 10/4 paths, scan interval 15 secs
Neighbor V
AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2001:DB8:12::1 4
1 2866 2865
4 0 0 2d00h 1
PE1#sh
bgp vpnv6 unicast vrf MSSK summary
BGP
router identifier 2.2.2.2, local AS number 100
BGP
table version is 4, main routing table version 4
2
network entries using 360 bytes of memory
2
path entries using 192 bytes of memory
6/2
BGP path/bestpath attribute entries using 888 bytes of memory
2
BGP AS-PATH entries using 48 bytes of memory
1
BGP extended community entries using 24 bytes of memory
0
BGP route-map cache entries using 0 bytes of memory
0
BGP filter-list cache entries using 0 bytes of memory
Bitfield
cache entries: current 2 (at peak 2) using 64 bytes of memory
BGP
using 1576 total bytes of memory
BGP
activity 6/0 prefixes, 10/4 paths, scan interval 15 secs
Neighbor V
AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2001:DB8:12::1 4
1 2866 2865
4 0 0 2d00h 1
PE1#sh
bgp vpnv6 unicast vrf MSSK
BGP
table version is 4, local router ID is 2.2.2.2
Status
codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin
codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route
Distinguisher: 100:1 (default for vrf MSSK)
*>
2001:DB8::1/128 2001:DB8:12::1 0 0 1 i
*>i2001:DB8::5/128 ::FFFF:4.4.4.4 0
100 0 5 i
PE1#sh
bgp vpnv6 unicast vrf MSSK neighbors 2001:DB8:12::1 advertised-routes
BGP
table version is 4, local router ID is 2.2.2.2
Status
codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin
codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route
Distinguisher: 100:1 (default for vrf MSSK)
*>i2001:DB8::5/128 ::FFFF:4.4.4.4 0
100 0 5 i
Total
number of prefixes 1
PE1#sh
bgp vpnv6 unicast vrf MSSK neighbors 2001:DB8:12::1 routes
BGP
table version is 4, local router ID is 2.2.2.2
Status
codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin
codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route
Distinguisher: 100:1 (default for vrf MSSK)
*>
2001:DB8::1/128 2001:DB8:12::1 0 0 1 i
Total
number of prefixes 1
PE2#sh
bgp vpnv6 unicast vrf MSSK summary
BGP
router identifier 4.4.4.4, local AS number 100
BGP
table version is 4, main routing table version 4
2
network entries using 360 bytes of memory
2
path entries using 192 bytes of memory
6/2
BGP path/bestpath attribute entries using 888 bytes of memory
2
BGP AS-PATH entries using 48 bytes of memory
1
BGP extended community entries using 24 bytes of memory
0
BGP route-map cache entries using 0 bytes of memory
0
BGP filter-list cache entries using 0 bytes of memory
Bitfield
cache entries: current 2 (at peak 2) using 64 bytes of memory
BGP
using 1576 total bytes of memory
BGP
activity 6/0 prefixes, 10/4 paths, scan interval 15 secs
Neighbor V
AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2001:DB8:45::5 4
5 2476 2476
4 0 0 1d17h 1
PE2#sh
bgp vpnv6 unicast vrf MSSK
BGP
table version is 4, local router ID is 4.4.4.4
Status
codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin
codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route
Distinguisher: 100:1 (default for vrf MSSK)
*>i2001:DB8::1/128 ::FFFF:2.2.2.2 0
100 0 1 i
*>
2001:DB8::5/128 2001:DB8:45::5 0 0 5 i
PE2#sh
bgp vpnv6 unicast vrf MSSK neigh
PE2#sh
bgp vpnv6 unicast vrf MSSK neighbors 2001:DB8:45::5 advert
PE2#sh
bgp vpnv6 unicast vrf MSSK neighbors 2001:DB8:45::5 advertised-routes
BGP
table version is 4, local router ID is 4.4.4.4
Status
codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin
codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route
Distinguisher: 100:1 (default for vrf MSSK)
*>i2001:DB8::1/128 ::FFFF:2.2.2.2 0
100 0 1 i
Total
number of prefixes 1
PE2#sh
bgp vpnv6 unicast vrf MSSK neighbors 2001:DB8:45::5 routes
BGP
table version is 4, local router ID is 4.4.4.4
Status
codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin
codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route
Distinguisher: 100:1 (default for vrf MSSK)
*>
2001:DB8::5/128 2001:DB8:45::5 0 0 5 i
Total
number of prefixes 1
CE1#sh
ipv6 route
IPv6
Routing Table - Default - 5 entries
Codes:
C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, M - MIPv6, R - RIP, I1 - ISIS
L1
I2 - ISIS L2, IA - ISIS interarea, IS -
ISIS summary, D - EIGRP
EX - EIGRP external
O
- OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA
ext 2
LC 2001:DB8::1/128 [0/0]
via Loopback0, receive
B 2001:DB8::5/128 [20/0]
via FE80::C801:18FF:FE0C:1C,
FastEthernet1/0
C 2001:DB8:12::/64 [0/0]
via FastEthernet1/0, directly connected
L 2001:DB8:12::1/128 [0/0]
via FastEthernet1/0, receive
L FF00::/8 [0/0]
via Null0, receive
CE2#sh
ipv6 route
IPv6
Routing Table - Default - 5 entries
Codes:
C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, M - MIPv6, R - RIP, I1 - ISIS
L1
I2 - ISIS L2, IA - ISIS interarea, IS -
ISIS summary, D - EIGRP
EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 -
OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA
ext 2
B 2001:DB8::1/128 [20/0]
via FE80::C803:18FF:FE0C:1D,
FastEthernet1/0
LC 2001:DB8::5/128 [0/0]
via Loopback0, receive
C 2001:DB8:45::/64 [0/0]
via FastEthernet1/0, directly connected
L 2001:DB8:45::5/128 [0/0]
via FastEthernet1/0, receive
L FF00::/8 [0/0]
via Null0, receive
PE1#sh
ipv6 route vrf MSSK
IPv6
Routing Table - MSSK - 5 entries
Codes:
C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, M - MIPv6, R - RIP, I1 - ISIS
L1
I2 - ISIS L2, IA - ISIS interarea, IS -
ISIS summary, D - EIGRP
EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 -
OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA
ext 2
B 2001:DB8::1/128 [20/0]
via FE80::C800:18FF:FE0C:1C,
FastEthernet1/0
B 2001:DB8::5/128 [200/0]
via 4.4.4.4%Default-IP-Routing-Table,
indirectly connected
C 2001:DB8:12::/64 [0/0]
via FastEthernet1/0, directly connected
L 2001:DB8:12::2/128 [0/0]
via FastEthernet1/0, receive
L FF00::/8 [0/0]
via Null0, receive
PE2#sh
ipv6 route vrf MSSK
IPv6
Routing Table - MSSK - 5 entries
Codes:
C - Connected, L - Local, S - Static, U - Per-user Static route
B
- BGP, M - MIPv6, R - RIP, I1 - ISIS L1
I2 - ISIS L2, IA - ISIS interarea, IS -
ISIS summary, D - EIGRP
EX - EIGRP external
O - OSPF Intra, OI - OSPF Inter, OE1 -
OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA
ext 2
B 2001:DB8::1/128 [200/0]
via 2.2.2.2%Default-IP-Routing-Table,
indirectly connected
B 2001:DB8::5/128 [20/0]
via FE80::C804:18FF:FE0C:1C,
FastEthernet1/1
C 2001:DB8:45::/64 [0/0]
via FastEthernet1/1, directly connected
L 2001:DB8:45::4/128 [0/0]
via FastEthernet1/1, receive
L FF00::/8 [0/0]
via Null0, receive
CE1#ping
2001:DB8::5 source loopback 0
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 2001:DB8::5, timeout is 2 seconds:
Packet
sent with a source address of 2001:DB8::1
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms
CE2#ping
2001:DB8::1 source loopback 0
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 2001:DB8::1, timeout is 2 seconds:
Packet
sent with a source address of 2001:DB8::5
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms
No comments:
Post a Comment