Issue
We will configure IPv6 addressing between
PEs and CEs and transport over the IPv4 MPLS backbone, i.e. 6VPE and OSPF will
be the PE-CE routing protocol (You will need to deploy a new IOS version in order
to configure OSPFv3 related commands, IOS version used is c7200-adventerprisek9-mz.152-4.S.bin)
Configuration
For
the basic configuration of the L3 MPLS VPN please refer to http://eng-mssk.blogspot.com/2012/10/mpls-l3-vpn-ipv6-6pe.html
We
will list current configuration of our elements
CE1
CE1#sh
run int f1/0
interface
FastEthernet1/0
ip address 192.1.12.1 255.255.255.0
duplex full
speed 100
ipv6 address 2001:DB8:12::1/64
CE1#sh
run int lo0
interface
Loopback0
ip address 1.1.1.1 255.255.255.255
ipv6 address 2001:DB8::1/128
ipv6
ospf 1 area 0
PE1
PE1#sh
run int f1/0
interface
FastEthernet1/0
vrf forwarding MSSK
ip address 192.1.12.2 255.255.255.0
duplex full
speed 100
ipv6 address 2001:DB8:12::2/64
PE1#sh
run int f1/1
interface
FastEthernet1/1
ip address 192.1.23.2 255.255.255.0
ip ospf 1 area 0
duplex full
speed 100
mpls ip
PE1#sh
run int lo0
interface
Loopback0
ip address 2.2.2.2 255.255.255.255
ip ospf 1 area 0
ipv6 address 2001:DB8::2/128
PE1#s
run | sec vrf def
vrf
definition MSSK
rd 100:1
route-target export 100:1
route-target import 100:1
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
P
P#sh
run int f1/0
interface
FastEthernet1/0
ip address 192.1.23.3 255.255.255.0
ip ospf 1 area 0
duplex full
speed 100
mpls ip
P#sh
run int f1/1
interface
FastEthernet1/1
ip address 192.1.34.3 255.255.255.0
ip ospf 1 area 0
duplex full
speed 100
mpls ip
P#sh
run int lo0
interface
Loopback0
ip address 3.3.3.3 255.255.255.255
ip ospf 1 area 0
end
PE2
PE2#sh
run int f1/0
interface
FastEthernet1/0
ip address 192.1.34.4 255.255.255.0
ip ospf 1 area 0
duplex full
speed 100
mpls ip
PE2#sh
run int f1/1
interface
FastEthernet1/1
vrf forwarding MSSK
ip address 192.1.45.4 255.255.255.0
duplex full
speed 100
ipv6 address 2001:DB8:45::4/64
PE2#sh
run int lo0
interface
Loopback0
ip address 4.4.4.4 255.255.255.255
ip ospf 1 area 0
ipv6 address 2001:DB8::4/128
ipv6 nd ra mtu suppress
PE1#s
run | sec vrf def
vrf
definition MSSK
rd 100:1
route-target export 100:1
route-target import 100:1
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
CE2
CE2#sh
run int f1/0
interface
FastEthernet1/0
ip address 192.1.45.5 255.255.255.0
duplex full
speed 100
ipv6 address 2001:DB8:45::5/64
CE2#sh
run int lo0
interface
Loopback0
ip address 5.5.5.5 255.255.255.255
ipv6 address 2001:DB8::5/128
ipv6 nd ra mtu suppress
Now,
we have configured OSPF process 101 between PEs and CEs and advertised the CEs
loopbacks
CE1
CE1#sh
run int f1/0
interface
FastEthernet1/0
ipv6
ospf 101 area 0
CE1#sh
run int lo0
interface
Loopback0
ipv6
ospf 101 area 0
PE1
PE1#sh
run | sec vrf def
vrf
definition MSSK
address-family
ipv6
PE1#sh
run int f1/0
interface
FastEthernet1/0
ospfv3
101 ipv6 area 0
PE1#sh
run | sec router bgp
router
bgp 100
address-family
vpnv6
neighbor 4.4.4.4 activate
neighbor 4.4.4.4 send-community both
exit-address-family
!
address-family ipv6 vrf MSSK
redistribute ospf 101
exit-address-family
PE1#
sh run | sec router ospfv
router
ospfv3 101
!
address-family ipv6 unicast
exit-address-family
!
address-family ipv6 unicast vrf MSSK
redistribute bgp 100
exit-address-family
PE2
PE2#sh
run | sec vrf def
vrf
definition MSSK
address-family ipv6
PE2#sh
run int f1/1
interface
FastEthernet1/1
ospfv3
101 ipv6 area 0
PE2#sh
run | sec router bgp
router
bgp 100
!
address-family vpnv6
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
address-family
ipv6 vrf MSSK
redistribute ospf 101
exit-address-family
PE2#sh
run | sec router ospfv
router
ospfv3 101
address-family
ipv6 unicast vrf MSSK
redistribute bgp 100
exit-address-family
CE2
CE2#sh
run int f1/0
interface
FastEthernet1/0
ipv6
ospf 101 area 0
CE2#sh
run int lo0
interface
Loopback0
ipv6
ospf 101 area 0
Verification
CE1#sh
ipv6 ospf neighbor
OSPFv3 Router with ID (1.1.1.1)
(Process ID 101)
Neighbor
ID Pri State Dead Time Interface ID Interface
192.1.12.2 1
FULL/DR 00:00:39 3 FastEthernet1/0
CE1#sh
ipv6 route ospf
IPv6
Routing Table - default - 5 entries
Codes:
C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
I2 - ISIS L2, IA - ISIS interarea, IS -
ISIS summary, D - EIGRP
EX - EIGRP external, ND - ND Default,
NDp - ND Prefix, DCE - Destination
NDr - Redirect, O - OSPF Intra, OI -
OSPF Inter, OE1 - OSPF ext 1
OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1,
ON2 - OSPF NSSA ext 2, l - LISP
OI 2001:DB8::5/128 [110/2]
via FE80::C801:35FF:FE47:1C,
FastEthernet1/0
CE1#ping
2001:DB8::5 source lo0
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 2001:DB8::5, timeout is 2 seconds:
Packet
sent with a source address of 2001:DB8::1
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms
CE2#sh
ipv6 ospf neighbor
OSPFv3 Router with ID (5.5.5.5)
(Process ID 101)
Neighbor
ID Pri State Dead Time Interface ID Interface
192.1.45.4 1 FULL/DR 00:00:39 4 FastEthernet1/0
CE2#sh
ipv6 route ospf
IPv6
Routing Table - default - 5 entries
Codes:
C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
I2 - ISIS L2, IA - ISIS interarea, IS -
ISIS summary, D - EIGRP
EX - EIGRP external, ND - ND Default,
NDp - ND Prefix, DCE - Destination
NDr - Redirect, O - OSPF Intra, OI -
OSPF Inter, OE1 - OSPF ext 1
OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1,
ON2 - OSPF NSSA ext 2, l - LISP
OI 2001:DB8::1/128 [110/2]
via FE80::C803:35FF:FE47:1D,
FastEthernet1/0
CE2#ping
2001:DB8::1 source lo0
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 2001:DB8::1, timeout is 2 seconds:
Packet
sent with a source address of 2001:DB8::5
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 16/17/20 ms
PE1#sh
bgp vpnv6 unicast all summary
BGP
router identifier 2.2.2.2, local AS number 100
BGP
table version is 4, main routing table version 4
2
network entries using 360 bytes of memory
2
path entries using 216 bytes of memory
2/2
BGP path/bestpath attribute entries using 288 bytes of memory
4
BGP extended community entries using 160 bytes of memory
0
BGP route-map cache entries using 0 bytes of memory
0
BGP filter-list cache entries using 0 bytes of memory
BGP
using 1024 total bytes of memory
BGP
activity 6/0 prefixes, 10/4 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer
InQ OutQ Up/Down State/PfxRcd
4.4.4.4 4 100 358
362 4 0
0 05:20:06 1
PE1#sh
bgp vpnv6 unicast all
BGP
table version is 4, local router ID is 2.2.2.2
Status
codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath,
b backup-path, f RT-Filter,
x best-external, a
additional-path, c RIB-compressed,
Origin
codes: i - IGP, e - EGP, ? - incomplete
RPKI
validation codes: V valid, I invalid, N Not found
Network Next Hop Metric LocPrf Weight Path
Route
Distinguisher: 100:1 (default for vrf MSSK)
*>
2001:DB8::1/128 :: 1 32768 ?
*>i 2001:DB8::5/128 ::FFFF:4.4.4.4 1
100 0 ?
PE1#sh
ipv6 route vrf MSSK
IPv6
Routing Table - MSSK - 5 entries
Codes:
C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
I2 - ISIS L2, IA - ISIS interarea, IS -
ISIS summary, D - EIGRP
EX - EIGRP external, ND - ND Default,
NDp - ND Prefix, DCE - Destination
NDr - Redirect, O - OSPF Intra, OI -
OSPF Inter, OE1 - OSPF ext 1
OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1,
ON2 - OSPF NSSA ext 2, l - LISP
O 2001:DB8::1/128 [110/1]
via FE80::C800:35FF:FE47:1C,
FastEthernet1/0
B 2001:DB8::5/128 [200/1]
via 4.4.4.4%default, indirectly connected
C 2001:DB8:12::/64 [0/0]
via FastEthernet1/0, directly connected
L 2001:DB8:12::2/128 [0/0]
via FastEthernet1/0, receive
L FF00::/8 [0/0]
via Null0, receive
PE1#sh
ospfv3 vrf MSSK neighbor
OSPFv3 101 address-family ipv6 vrf
MSSK (router-id 192.1.12.2)
Neighbor
ID Pri State Dead Time Interface ID Interface
1.1.1.1 1
FULL/BDR 00:00:36 3 FastEthernet1/0
PE2#sh
bgp vpnv6 unicast all summary
BGP
router identifier 4.4.4.4, local AS number 100
BGP
table version is 4, main routing table version 4
2
network entries using 360 bytes of memory
2
path entries using 216 bytes of memory
2/2
BGP path/bestpath attribute entries using 288 bytes of memory
4
BGP extended community entries using 160 bytes of memory
0
BGP route-map cache entries using 0 bytes of memory
0
BGP filter-list cache entries using 0 bytes of memory
BGP
using 1024 total bytes of memory
BGP
activity 6/0 prefixes, 10/4 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer
InQ OutQ Up/Down State/PfxRcd
2.2.2.2 4 100 369
366 4 0
0 05:26:43 1
PE2#sh
ipv6 route vrf MSSK
IPv6
Routing Table - MSSK - 5 entries
Codes:
C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
I2 - ISIS L2, IA - ISIS interarea, IS -
ISIS summary, D - EIGRP
EX - EIGRP external, ND - ND Default,
NDp - ND Prefix, DCE - Destination
NDr - Redirect, O - OSPF Intra, OI -
OSPF Inter, OE1 - OSPF ext 1
OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1,
ON2 - OSPF NSSA ext 2, l - LISP
B 2001:DB8::1/128 [200/1]
via 2.2.2.2%default, indirectly connected
O 2001:DB8::5/128 [110/1]
via FE80::C804:35FF:FE47:1C,
FastEthernet1/1
C 2001:DB8:45::/64 [0/0]
via FastEthernet1/1, directly connected
L 2001:DB8:45::4/128 [0/0]
via FastEthernet1/1, receive
L FF00::/8 [0/0]
via Null0, receive
PE2#sh
ospfv3 vrf MSSK neighbor
OSPFv3 101 address-family ipv6 vrf
MSSK (router-id 192.1.45.4)
Neighbor
ID Pri State Dead Time Interface ID Interface
5.5.5.5 1
FULL/BDR 00:00:31 3 FastEthernet1/1
PE1#sh
ipv6 route vrf MSSK ospf
IPv6
Routing Table - MSSK - 5 entries
Codes:
C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
I2 - ISIS L2, IA - ISIS interarea, IS -
ISIS summary, D - EIGRP
EX - EIGRP external, ND - ND Default,
NDp - ND Prefix, DCE - Destination
NDr - Redirect, O - OSPF Intra, OI -
OSPF Inter, OE1 - OSPF ext 1
OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1,
ON2 - OSPF NSSA ext 2, l - LISP
O 2001:DB8::1/128 [110/1]
via FE80::C800:35FF:FE47:1C,
FastEthernet1/0
PE2#sh
ipv6 route vrf MSSK ospf
IPv6
Routing Table - MSSK - 5 entries
Codes:
C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
I2 - ISIS L2, IA - ISIS interarea, IS -
ISIS summary, D - EIGRP
EX - EIGRP external, ND - ND Default,
NDp - ND Prefix, DCE - Destination
NDr - Redirect, O - OSPF Intra, OI -
OSPF Inter, OE1 - OSPF ext 1
OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1,
ON2 - OSPF NSSA ext 2, l - LISP
O 2001:DB8::5/128 [110/1]
via FE80::C804:35FF:FE47:1C,
FastEthernet1/1
No comments:
Post a Comment