Issue
How the OSPF Process ID and the OSPF
Domain-ID does affect routing?
Configuration
We
will start with basic MPLS L3 VPN configuration with OSPF as the PE-CE routing
protocol
R1
R1#sh
run int f0/0
interface
FastEthernet0/0
ip address 192.1.15.1 255.255.255.0
speed 100
full-duplex
mpls ip
R1#sh
run int f0/1
interface
FastEthernet0/1
ip vrf forwarding RED
ip address 192.1.14.1 255.255.255.0
speed 100
full-duplex
R1#sh
run int f1/0
interface
FastEthernet1/0
ip vrf forwarding BLUE
ip address 192.1.17.1 255.255.255.0
speed 100
full-duplex
R1#sh
run int lo0
interface
Loopback0
ip address 1.1.1.1 255.255.255.255
ip
vrf BLUE
rd 150:10
route-target export 150:10
route-target import 150:10
ip
vrf RED
rd 300:10
route-target export 300:10
route-target import 300:10
R1#sh
run | sec router ospf
router
ospf 300 vrf RED
router-id 192.1.14.1
log-adjacency-changes
redistribute bgp 10 subnets
network 192.1.14.1 0.0.0.0 area 0
router
ospf 150 vrf BLUE
router-id 192.1.17.1
log-adjacency-changes
redistribute bgp 10 subnets
network 192.1.17.1 0.0.0.0 area 0
router
ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 192.1.15.1 0.0.0.0 area 0
R1#sh
run | sec router bgp
router
bgp 10
no synchronization
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 10
neighbor 3.3.3.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf RED
redistribute ospf 300 vrf RED
no synchronization
exit-address-family
!
address-family ipv4 vrf BLUE
redistribute ospf 150 vrf BLUE
no synchronization
exit-address-family
mpls
label protocol ldp
mpls
ldp router-id Loopback0 force
R2
R2#sh
run int f0/0
interface
FastEthernet0/0
ip address 192.1.25.2 255.255.255.0
speed 100
full-duplex
mpls ip
R2#sh
run int f0/1
interface
FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
R2#sh
run int s0/0
interface
Serial0/0
ip address 192.1.23.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
mpls ip
clock rate 64000
frame-relay map ip 192.1.23.3 203 broadcast
no frame-relay inverse-arp
R2#sh
run int lo0
interface
Loopback0
ip address 2.2.2.2 255.255.255.255
R2#sh
run | sec router ospf
router
ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 192.1.23.2 0.0.0.0 area 0
network 192.1.25.2 0.0.0.0 area 0
R2#sh
run | inc ldp
mpls
label protocol ldp
mpls
ldp router-id Loopback0 force
R3#sh
run int f0/0
interface
FastEthernet0/0
ip vrf forwarding RED
ip address 192.1.36.3 255.255.255.0
speed 100
full-duplex
R3
R3#sh
run int f0/1
interface
FastEthernet0/1
ip vrf forwarding BLUE
ip address 192.1.38.3 255.255.255.0
speed 100
full-duplex
R3#sh
run int ser0/0
interface
Serial0/0
ip address 192.1.23.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
mpls ip
clock rate 64000
frame-relay map ip 192.1.23.2 302 broadcast
no frame-relay inverse-arp
R3#sh
run int lo0
interface
Loopback0
ip address 3.3.3.3 255.255.255.255
end
ip
vrf BLUE
rd 150:10
route-target export 150:10
route-target import 150:10
ip
vrf RED
rd 300:10
route-target export 300:10
route-target import 300:10
R3#sh
run | sec router ospf
router
ospf 300 vrf RED
router-id 192.1.36.3
log-adjacency-changes
redistribute bgp 10 subnets
network 192.1.36.3 0.0.0.0 area 0
router
ospf 150 vrf BLUE
router-id 192.1.38.3
log-adjacency-changes
redistribute bgp 10 subnets
network 192.1.38.3 0.0.0.0 area 0
router
ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 192.1.23.3 0.0.0.0 area 0
R3#sh
run | sec router bgp
router
bgp 10
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 10
neighbor 1.1.1.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
exit-address-family
!
address-family ipv4 vrf RED
redistribute ospf 300 vrf RED
no synchronization
exit-address-family
!
address-family ipv4 vrf BLUE
redistribute ospf 150 vrf BLUE
no synchronization
exit-address-family
R3#sh
run | inc ldp
mpls
label protocol ldp
mpls
ldp router-id Loopback0 force
R4
R4#sh
run int f0/0
interface
FastEthernet0/0
ip address 192.1.14.4 255.255.255.0
speed 100
full-duplex
R4#sh
run int lo0
interface
Loopback0
ip address 4.4.4.4 255.255.255.255
R4#sh
run | sec router ospf
router
ospf 300
router-id 4.4.4.4
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 192.1.14.4 0.0.0.0 area 0
R5
R5#sh
run int f0/0
interface
FastEthernet0/0
ip address 192.1.15.5 255.255.255.0
speed 100
full-duplex
mpls ip
R5#sh
run int f0/1
interface
FastEthernet0/1
ip address 192.1.25.5 255.255.255.0
speed 100
full-duplex
mpls ip
R5#sh
run int lo0
interface
Loopback0
ip address 5.5.5.5 255.255.255.255
R5#sh
run | sec router ospf
router
ospf 1
router-id 5.5.5.5
log-adjacency-changes
network 5.5.5.5 0.0.0.0 area 0
network 192.1.15.5 0.0.0.0 area 0
network 192.1.25.5 0.0.0.0 area 0
R5#sh
run | inc ldp
mpls
label protocol ldp
mpls
ldp router-id Loopback0 force
R6
R6#sh
run int f0/0
interface
FastEthernet0/0
ip address 192.1.36.6 255.255.255.0
speed 100
full-duplex
R6#sh
run int lo0
interface
Loopback0
ip address 6.6.6.6 255.255.255.255
R6#sh
run | sec router ospf
router
ospf 300
router-id 6.6.6.6
log-adjacency-changes
network 6.6.6.6 0.0.0.0 area 0
network 192.1.36.6 0.0.0.0 area 0
R7
R7#sh
run int f0/0
interface
FastEthernet0/0
ip address 192.1.17.7 255.255.255.0
speed 100
full-duplex
R7#sh
run int lo0
interface
Loopback0
ip address 7.7.7.7 255.255.255.255
R7#sh
run | sec router ospf
router
ospf 150
router-id 7.7.7.7
log-adjacency-changes
network 7.7.7.7 0.0.0.0 area 0
network 192.1.17.7 0.0.0.0 area 0
R8
R8#sh
run int f0/0
interface
FastEthernet0/0
ip address 192.1.38.8 255.255.255.0
speed 100
full-duplex
R8#sh
run int lo0
interface
Loopback0
ip address 8.8.8.8 255.255.255.255
R8#sh
run | sec router ospf
router
ospf 150
router-id 8.8.8.8
log-adjacency-changes
network 8.8.8.8 0.0.0.0 area 0
network 192.1.38.8 0.0.0.0 area 0
Verification
R4#sh
ip ospf neighbor
Neighbor
ID Pri State Dead Time Address Interface
192.1.14.1 1
FULL/DR 00:00:32 192.1.14.1 FastEthernet0/0
R4#sh
ip route ospf
6.0.0.0/32 is subnetted, 1 subnets
O
IA 6.6.6.6 [110/12] via 192.1.14.1,
00:14:18, FastEthernet0/0
O
IA 192.1.36.0/24 [110/2] via 192.1.14.1, 00:14:33, FastEthernet0/0
R4#ping
6.6.6.6 source loopback 0
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
Packet
sent with a source address of 4.4.4.4
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 16/17/20 ms
R4#sh
ip ospf database
OSPF Router with ID (4.4.4.4)
(Process ID 300)
Router Link States (Area 0)
Link
ID ADV Router Age Seq# Checksum Link count
4.4.4.4 4.4.4.4 1247 0x80000003 0x00A6A4 2
192.1.14.1 192.1.14.1 1250 0x80000002 0x0030BB 1
Net Link States (Area 0)
Link
ID ADV Router Age Seq# Checksum
192.1.14.1 192.1.14.1 1250 0x80000001 0x008C2B
Summary Net Link States (Area
0)
Link
ID ADV Router Age Seq# Checksum
6.6.6.6 192.1.14.1 902 0x80000001 0x0024A4
192.1.36.0 192.1.14.1 917 0x80000001 0x007193
R6#sh
ip ospf neighbor
Neighbor
ID Pri State Dead Time Address Interface
192.1.36.3 1
FULL/BDR 00:00:38 192.1.36.3 FastEthernet0/0
R6#sh
ip route ospf
O
IA 192.1.14.0/24 [110/11] via 192.1.36.3, 00:16:04, FastEthernet0/0
4.0.0.0/32 is subnetted, 1 subnets
O
IA 4.4.4.4 [110/12] via 192.1.36.3,
00:16:04, FastEthernet0/0
R6#ping
4.4.4.4 source loopback 0
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
Packet
sent with a source address of 6.6.6.6
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms
R6#sh
ip ospf database
OSPF Router with ID (6.6.6.6)
(Process ID 300)
Router Link States (Area 0)
Link
ID ADV Router Age Seq# Checksum Link count
6.6.6.6 6.6.6.6 978 0x80000003 0x00896D 2
192.1.36.3 192.1.36.3 979 0x80000003 0x005727 1
Net Link States (Area 0)
Link
ID ADV Router Age Seq# Checksum
192.1.36.6 6.6.6.6 978 0x80000001 0x006CC8
Summary Net Link States (Area
0)
Link
ID ADV Router Age Seq# Checksum
4.4.4.4 192.1.36.3 1212 0x80000001 0x007F42
192.1.14.0 192.1.36.3 1212 0x80000001 0x00BD45
R7#sh
ip ospf neighbor
Neighbor
ID Pri State Dead Time Address
Interface
192.1.17.1 1
FULL/DR 00:00:37 192.1.17.1 FastEthernet0/0
R7#sh
ip rou
R7#sh
ip route os
R7#sh
ip route ospf
O
IA 192.1.38.0/24 [110/2] via 192.1.17.1, 00:16:17, FastEthernet0/0
8.0.0.0/32 is subnetted, 1 subnets
O
IA 8.8.8.8 [110/3] via 192.1.17.1,
00:16:01, FastEthernet0/0
R7#ping
8.8.8.8 source loopback 0
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
Packet
sent with a source address of 7.7.7.7
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 16/17/20 ms
R7#sh
ip ospf database
OSPF Router with ID (7.7.7.7)
(Process ID 150)
Router Link States (Area 0)
Link
ID ADV Router Age Seq# Checksum Link count
7.7.7.7 7.7.7.7 1105 0x80000003 0x0025F8 2
192.1.17.1 192.1.17.1 1106 0x80000002 0x003CA3 1
Net Link States (Area 0)
Link
ID ADV Router Age Seq# Checksum
192.1.17.1 192.1.17.1 1106 0x80000001 0x00089A
Summary Net Link States (Area
0)
Link
ID ADV Router Age Seq# Checksum
8.8.8.8 192.1.17.1 973 0x80000001 0x00586E
192.1.38.0 192.1.17.1 989 0x80000001 0x0046B9
R8#sh
ip ospf neighbor
Neighbor
ID Pri State Dead Time Address Interface
192.1.38.3 1
FULL/BDR 00:00:38 192.1.38.3 FastEthernet0/0
R8#sh
ip route ospf
7.0.0.0/32 is subnetted, 1 subnets
O
IA 7.7.7.7 [110/3] via 192.1.38.3,
00:16:42, FastEthernet0/0
O
IA 192.1.17.0/24 [110/2] via 192.1.38.3, 00:16:42, FastEthernet0/0
R8#ping
7.7.7.7 source loopback 0
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
Packet
sent with a source address of 8.8.8.8
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms
R8#sh
ip ospf database
OSPF Router with ID (8.8.8.8)
(Process ID 150)
Router Link States (Area 0)
Link
ID ADV Router Age Seq# Checksum Link count
8.8.8.8 8.8.8.8 1015 0x80000003 0x004F90 2
192.1.38.3 192.1.38.3 1015 0x80000004 0x00CEAD 1
Net Link States (Area 0)
Link
ID ADV Router Age Seq# Checksum
192.1.38.8 8.8.8.8 1015 0x80000001 0x0064BA
Summary Net Link States (Area
0)
Link
ID ADV Router Age
Seq# Checksum
7.7.7.7 192.1.38.3 1106 0x80000001 0x00E6CC
192.1.17.0 192.1.38.3 1256 0x80000001 0x008E6F
R1#sh
ip route vrf RED
Routing
Table: RED
Codes:
C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O -
OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 -
OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF
external type 2
i - IS-IS, su - IS-IS summary, L1 -
IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate
default, U - per-user static route
o - ODR, P - periodic downloaded static
route
Gateway
of last resort is not set
C 192.1.14.0/24 is directly connected,
FastEthernet0/1
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/2] via 192.1.14.4,
00:22:48, FastEthernet0/1
6.0.0.0/32 is subnetted, 1 subnets
B 6.6.6.6 [200/11] via 3.3.3.3, 00:17:05
B 192.1.36.0/24 [200/0] via 3.3.3.3, 00:17:20
R1#sh
ip route vrf BLUE
Routing
Table: BLUE
Codes:
C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O -
OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 -
OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF
external type 2
i - IS-IS, su - IS-IS summary, L1 -
IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate
default, U - per-user static route
o - ODR, P - periodic downloaded static
route
Gateway
of last resort is not set
7.0.0.0/32 is subnetted, 1 subnets
O 7.7.7.7 [110/2] via 192.1.17.7,
00:19:01, FastEthernet1/0
B 192.1.38.0/24 [200/0] via 3.3.3.3, 00:17:08
8.0.0.0/32 is subnetted, 1 subnets
B 8.8.8.8 [200/2] via 3.3.3.3, 00:16:53
C 192.1.17.0/24 is directly connected,
FastEthernet1/0
R1#ping
vrf RED 6.6.6.6
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 12/12/16 ms
R1#ping
vrf RED 4.4.4.4
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
R1#ping
vrf BLUE 7.7.7.7
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
R1#ping
vrf BLUE 8.8.8.8
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 12/12/12 ms
R1#sh
bgp vpnv4 unicast all summary
BGP
router identifier 1.1.1.1, local AS number 10
BGP
table version is 20, main routing table version 20
8
network entries using 1096 bytes of memory
8
path entries using 544 bytes of memory
9/8
BGP path/bestpath attribute entries using 1116 bytes of memory
4
BGP extended community entries using 160 bytes of memory
0
BGP route-map cache entries using 0 bytes of memory
0
BGP filter-list cache entries using 0 bytes of memory
BGP
using 2916 total bytes of memory
BGP
activity 9/1 prefixes, 9/1 paths, scan interval 15 secs
Neighbor V
AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
3.3.3.3 4
10 36 31
20 0 0 00:22:08 4
R1#sh
bgp vpnv4 unicast all
BGP
table version is 20, local router ID is 1.1.1.1
Status
codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin
codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route
Distinguisher: 150:10 (default for vrf BLUE)
*>
7.7.7.7/32 192.1.17.7 2 32768 ?
*>i8.8.8.8/32 3.3.3.3 2 100
0 ?
*>
192.1.17.0 0.0.0.0 0 32768 ?
*>i192.1.38.0 3.3.3.3 0 100
0 ?
Route
Distinguisher: 300:10 (default for vrf RED)
*>
4.4.4.4/32 192.1.14.4 2 32768 ?
*>i6.6.6.6/32 3.3.3.3 11 100
0 ?
*>
192.1.14.0 0.0.0.0 0 32768 ?
*>i192.1.36.0 3.3.3.3 0 100
0 ?
R1#sh
mpls interfaces
Interface IP Tunnel Operational
FastEthernet0/0 Yes (ldp) No
Yes
R1#sh
mpls ldp neighbor
Peer LDP Ident: 5.5.5.5:0; Local LDP Ident
1.1.1.1:0
TCP connection: 5.5.5.5.60478 - 1.1.1.1.646
State: Oper; Msgs sent/rcvd: 36/36;
Downstream
Up time: 00:22:34
LDP discovery sources:
FastEthernet0/0, Src IP addr:
192.1.15.5
Addresses bound to peer LDP Ident:
192.1.15.5 192.1.25.5 5.5.5.5
R1#sh
bgp vpnv4 unicast all neighbors 3.3.3.3 advertised-routes
BGP
table version is 20, local router ID is 1.1.1.1
Status
codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin
codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route
Distinguisher: 150:10 (default for vrf BLUE)
*>
7.7.7.7/32 192.1.17.7 2 32768 ?
*>
192.1.17.0 0.0.0.0 0 32768 ?
Route
Distinguisher: 300:10 (default for vrf RED)
*>
4.4.4.4/32 192.1.14.4 2 32768 ?
*>
192.1.14.0 0.0.0.0 0 32768 ?
Total
number of prefixes 4
Now
, as we can see from the outputs above that CEs receive routes as IA routes and
that is because the Domain IDs values are the same which are derived from the
process IDs
R1#sh
ip ospf | inc 150
Routing Process "ospf 150" with ID
192.1.17.1
Domain ID type 0x0005, value 0.0.0.150
R1#sh
ip ospf | inc 300
Routing Process "ospf 300" with ID
192.1.14.1
Now,
let us configure the domain IDs value on our PEs: R1 and R3 and see the effect
R4#sh
ip route 6.6.6.6
Routing
entry for 6.6.6.6/32
Known via "ospf 300", distance 110,
metric 12, type inter area
Last update from 192.1.14.1 on
FastEthernet0/0, 00:23:11 ago
Routing Descriptor Blocks:
* 192.1.14.1, from 192.1.14.1, 00:23:11 ago,
via FastEthernet0/0
Route metric is 12, traffic share count
is 1
R1(config)#router
ospf 300 vrf RED
R1(config-router)#domain-id
0.0.0.60
R1(config-router)#router
ospf 150 vrf BLUE
R1(config-router)#domain-id
0.0.0.50
R1#clear
ip ospf process
Reset
ALL OSPF processes? [no]: yes
R3(config)#router
ospf 300 vrf RED
R3(config-router)#domain-id
0.0.0.60
R3(config-router)#router
ospf 150 vrf BLUE
R3(config-router)#domain-id
0.0.0.50
R3#clear
ip ospf process
Reset
ALL OSPF processes? [no]: yes
R1#sh
ip ospf | inc 150
Routing
Process "ospf 150" with ID 192.1.17.1
Domain ID type 0x0005, value 0.0.0.50
Routing Process "ospf 300" with ID
192.1.14.1
Domain ID type 0x0005, value 0.0.0.60
R1#sh
ip ospf | inc 150
Routing Process "ospf 150" with ID
192.1.38.3
Domain ID type 0x0005, value 0.0.0.50
Routing Process "ospf 300" with ID
192.1.36.3
Domain ID type 0x0005, value 0.0.0.60
R4#sh
ip route ospf | inc 6.6.6.6
O
IA 6.6.6.6 [110/12] via 192.1.14.1, 00:00:59,
FastEthernet0/0
R4#sh
ip route 6.6.6.6
Routing
entry for 6.6.6.6/32
Known via "ospf 300", distance 110,
metric 12, type inter area
Last update from 192.1.14.1 on
FastEthernet0/0, 00:01:17 ago
Routing Descriptor Blocks:
* 192.1.14.1, from 192.1.14.1, 00:01:17 ago,
via FastEthernet0/0
Route metric is 12, traffic share count
is 1
All
is the same till now, let us change the domain IDs and the process IDs are the
same on both PEs and CEs (we will work on vrf RED)
R1#sh
run | sec router ospf 300
router
ospf 300 vrf RED
router-id 192.1.14.1
domain-id 0.0.0.60
log-adjacency-changes
redistribute bgp 10 subnets
network 192.1.14.1 0.0.0.0 area 0
R1#conf
t
Enter
configuration commands, one per line.
End with CNTL/Z.
R1(config)#router
ospf 300 vrf RED
R1(config-router)#domain-id
0.0.0.120
R1(config-router)#end
R1#clear
ip ospf process
Reset
ALL OSPF processes? [no]: yes
R4#sh
ip route ospf | inc 6.6.6.6
O
E2 6.6.6.6 [110/11] via 192.1.14.1, 00:00:00,
FastEthernet0/0
R4#sh
ip route 6.6.6.6
Routing
entry for 6.6.6.6/32
Known via "ospf 300", distance 110,
metric 11
Tag Complete, Path Length == 1, AS 10, , type
extern 2, forward metric 1
Last update from 192.1.14.1 on
FastEthernet0/0, 00:00:09 ago
Routing Descriptor Blocks:
* 192.1.14.1, from 192.1.14.1, 00:00:09 ago,
via FastEthernet0/0
Route metric is 11, traffic share count
is 1
Route tag 3489660938
Now,
let us get the domain IDs the same and change the process ID
R1(config)#no
router ospf 300 vrf RED
R1(config)#
router
ospf 301 vrf RED
R1(config-router)#
router-id 192.1.14.1
R1(config-router)#
domain-id 0.0.0.60
R1(config-router)#
log-adjacency-changes
R1(config-router)#
redistribute bgp 10 subnets
R1(config-router)#
network 192.1.14.1 0.0.0.0 area 0
R4#sh
ip route ospf | inc 6.6.6.6
O
IA 6.6.6.6 [110/12] via 192.1.14.1, 00:00:01,
FastEthernet0/0
R4#sh
ip route 6.6.6.6
Routing
entry for 6.6.6.6/32
Known via "ospf 300", distance 110,
metric 12, type inter area
Last update from 192.1.14.1 on
FastEthernet0/0, 00:00:12 ago
Routing Descriptor Blocks:
* 192.1.14.1, from 192.1.14.1, 00:00:12 ago,
via FastEthernet0/0
Route metric is 12, traffic share count
is 1
So
changing the process IDs and the domain IDs value the same will not affect the
route to be IA or E (1|2), let us now remove the domain IDs configuration
R1#sh
run | sec router ospf 301
router
ospf 301 vrf RED
router-id 192.1.14.1
domain-id 0.0.0.60
log-adjacency-changes
redistribute bgp 10 subnets
network 192.1.14.1 0.0.0.0 area 0
R1#conf
t
Enter
configuration commands, one per line.
End with CNTL/Z.
R1(config)#router
ospf 301 vrf RED
R1(config-router)#no domain-id 0.0.0.60
R1(config-router)#end
R3(config)#router
ospf 150 vrf BLUE
R3(config-router)#router
ospf 300 vrf RED
R3(config-router)#no
domain-id 0.0.0.60
R4#sh
ip route ospf | inc 6.6.6.6
O
E2 6.6.6.6 [110/11] via 192.1.14.1, 00:00:00,
FastEthernet0/0
R4#sh
ip route 6.6.6.6
Routing
entry for 6.6.6.6/32
Known via "ospf 300", distance 110,
metric 11
Tag Complete, Path Length == 1, AS 10, , type
extern 2, forward metric 1
Last update from 192.1.14.1 on
FastEthernet0/0, 00:00:03 ago
Routing Descriptor Blocks:
* 192.1.14.1, from 192.1.14.1, 00:00:03 ago,
via FastEthernet0/0
Route metric is 11, traffic share count
is 1
Route tag 3489660938
.net
file
For
anyone want to lab it up, please find the .net file below
autostart
= False
[127.0.0.1:7200]
workingdir = /tmp
udp = 10001
[[3725]]
image =
INE/c3725-adventerprisek9-mz.124-18.bin
ram = 128
ghostios = True
[[ROUTER R4]]
model = 3725
console = 2004
f0/0 = R1 f0/1
x = -283.0
y = 102.0
[[ROUTER R5]]
model = 3725
console = 2005
f0/0 = R1 f0/0
f0/1 = R2 f0/0
x = -38.0
y = -165.0
[[ROUTER R6]]
model = 3725
console = 2006
f0/0 = R3 f0/0
x = 58.0
y = 99.0
[[ROUTER R7]]
model = 3725
console = 2007
f0/0 = R1 f1/0
x = -150.0
y = 103.0
[[ROUTER R1]]
model = 3725
console = 2001
f0/0 = R5 f0/0
f0/1 = R4 f0/0
slot1 = NM-1FE-TX
f1/0 = R7 f0/0
x = -223.0
y = -16.0
[[ROUTER R2]]
model = 3725
console = 2002
wic0/0 = WIC-2T
s0/0 = FR1 2
f0/0 = R5 f0/1
x = 87.0
y = -87.0
[[ROUTER R3]]
model = 3725
console = 2003
wic0/0 = WIC-2T
s0/0 = FR1 3
f0/0 = R6 f0/0
f0/1 = R8 f0/0
x = 175.0
y = -17.0
[[ROUTER R8]]
model = 3725
console = 2008
f0/0 = R3 f0/1
x = 199.0
y = 97.0
[[FRSW FR1]]
2:203 = 3:302
3:302 = 2:203
2 = R2 s0/0
3 = R3 s0/0
x = 193.5
y = -109.5
No comments:
Post a Comment