Issue
In this
example we will examine L2VPN with AToM
Our CEs
in this example are R1 and R5
Our PEs
are R2 and R4, and R3 is the P
We will
run OSPF as the IGP inside the MPLS backbone and we will configure EIGRP as the
routing protocol running between the CEs
R1 and R2
will run back to back frame-relay with R2 acting as the frame relay switch
Configuration
R1
R1#sh
run int s0/0
interface
Serial0/0
no ip address
encapsulation frame-relay
clock rate 64000
no frame-relay inverse-arp
R1#sh
run int s0/0.1
interface
Serial0/0.1 point-to-point
ip address 192.1.15.1 255.255.255.0
snmp trap link-status
frame-relay interface-dlci 100
R1#sh
run int lo0
interface
Loopback0
ip address 1.1.1.1 255.255.255.255
end
R1#sh
run | sec router eigrp
router
eigrp 15
network 1.1.1.1 0.0.0.0
network 192.1.15.1 0.0.0.0
no auto-summary
R2
R2#sh
run int s0/0
interface
Serial0/0
no ip address
encapsulation frame-relay
clock rate 64000
no frame-relay inverse-arp
frame-relay intf-type dce
R2#sh
run int f0/0
interface
FastEthernet0/0
ip address 192.1.23.2 255.255.255.0
speed 100
full-duplex
mpls ip
interface
Loopback0
ip address 2.2.2.2 255.255.255.255
R2#sh
run | inc switching
frame-relay
switching
R2#sh
run | sec connect
connect
FR Serial0/0 100 l2transport
xconnect 4.4.4.4 15 pw-class MSSK
R2#sh
run | sec router ospf
router
ospf 1
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 192.1.23.2 0.0.0.0 area 0
pseudowire-class
MSSK
encapsulation mpls
interworking ip
mpls
label protocol ldp
mpls
ldp router-id Loopback0 force
R3
R3#sh
run int f0/0
interface
FastEthernet0/0
ip address 192.1.23.3 255.255.255.0
speed 100
full-duplex
mpls ip
R3#sh
run int f0/1
interface
FastEthernet0/1
ip address 192.1.34.3 255.255.255.0
speed 100
full-duplex
mpls ip
R3#sh
run int lo0
interface
Loopback0
ip address 3.3.3.3 255.255.255.255
R3#sh
run | sec router ospf
router
ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 192.1.23.3 0.0.0.0 area 0
network 192.1.34.3 0.0.0.0 area 0
mpls
label protocol ldp
mpls
ldp router-id Loopback0 force
R4
R4#sh
run int f0/0
interface
FastEthernet0/0
ip address 192.1.34.4 255.255.255.0
speed 100
full-duplex
mpls ip
R4#sh
run int f0/1
interface
FastEthernet0/1
no ip address
speed 100
full-duplex
xconnect 2.2.2.2 15 pw-class MSSK
R4#sh
run int lo0
interface
Loopback0
ip address 4.4.4.4 255.255.255.255
R4#sh
run | sec router ospf
router
ospf 1
router-id 4.4.4.4
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 192.1.34.4 0.0.0.0 area 0
R4#sh
run | sec pse
pseudowire-class
MSSK
encapsulation mpls
interworking ip
mpls
label protocol ldp
mpls
ldp router-id Loopback0 force
R5
R5#sh
run int f0/0
interface
FastEthernet0/0
ip address 192.1.15.5 255.255.255.0
speed 100
full-duplex
R5#sh
run int lo0
interface
Loopback0
ip address 5.5.5.5 255.255.255.255
R5#sh
run | sec router eigrp
router
eigrp 15
network 5.5.5.5 0.0.0.0
network 192.1.15.5 0.0.0.0
no auto-summary
Verification
R2#sh
mpls ldp neighbor
Peer LDP Ident: 3.3.3.3:0; Local LDP Ident
2.2.2.2:0
TCP connection: 3.3.3.3.25091 -
2.2.2.2.646
State: Oper; Msgs sent/rcvd: 64/64;
Downstream
Up time: 00:48:56
LDP discovery sources:
FastEthernet0/0, Src IP addr:
192.1.23.3
Addresses bound to peer LDP Ident:
192.1.23.3 192.1.34.3 3.3.3.3
Peer LDP Ident: 4.4.4.4:0; Local LDP Ident
2.2.2.2:0
TCP connection: 4.4.4.4.22816 -
2.2.2.2.646
State: Oper; Msgs sent/rcvd: 61/61;
Downstream
Up time: 00:46:17
LDP discovery sources:
Targeted Hello 2.2.2.2 -> 4.4.4.4,
active, passive
Addresses bound to peer LDP Ident:
192.1.34.4 4.4.4.4
R2#sh
mpls ldp neighbor 4.4.4.4 detail
Peer LDP Ident: 4.4.4.4:0; Local LDP Ident
2.2.2.2:0
TCP connection: 4.4.4.4.22816 -
2.2.2.2.646
State: Oper; Msgs sent/rcvd: 61/61;
Downstream; Last TIB rev sent 10
Up time: 00:46:24; UID: 2; Peer Id 1;
LDP discovery sources:
Targeted Hello 2.2.2.2 -> 4.4.4.4,
active, passive;
holdtime: infinite, hello interval:
10000 ms
Addresses bound to peer LDP Ident:
192.1.34.4 4.4.4.4
Peer holdtime: 180000 ms; KA interval:
60000 ms; Peer state: estab
Clients: Dir Adj Client
R3#sh
mpls ldp neighbor
Peer LDP Ident: 2.2.2.2:0; Local LDP Ident
3.3.3.3:0
TCP connection: 2.2.2.2.646 -
3.3.3.3.25091
State: Oper; Msgs sent/rcvd: 64/64;
Downstream
Up time: 00:49:18
LDP discovery sources:
FastEthernet0/0, Src IP addr:
192.1.23.2
Addresses bound to peer LDP Ident:
192.1.23.2 2.2.2.2
Peer LDP Ident: 4.4.4.4:0; Local LDP Ident
3.3.3.3:0
TCP connection: 4.4.4.4.16338 -
3.3.3.3.646
State: Oper; Msgs sent/rcvd: 65/65;
Downstream
Up time: 00:49:05
LDP discovery sources:
FastEthernet0/1, Src IP addr:
192.1.34.4
Addresses bound to peer LDP Ident:
192.1.34.4 4.4.4.4
R4#sh
mpls ldp neighbor
Peer LDP Ident: 3.3.3.3:0; Local LDP Ident
4.4.4.4:0
TCP connection: 3.3.3.3.646 -
4.4.4.4.16338
State: Oper; Msgs sent/rcvd: 66/65;
Downstream
Up time: 00:49:25
LDP discovery sources:
FastEthernet0/0, Src IP addr:
192.1.34.3
Addresses bound to peer LDP Ident:
192.1.23.3 192.1.34.3 3.3.3.3
Peer LDP Ident: 2.2.2.2:0; Local LDP Ident
4.4.4.4:0
TCP connection: 2.2.2.2.646 -
4.4.4.4.22816
State: Oper; Msgs sent/rcvd: 62/62; Downstream
Up time: 00:47:00
LDP discovery sources:
Targeted Hello 4.4.4.4 -> 2.2.2.2,
active, passive
Addresses bound to peer LDP Ident:
192.1.23.2 2.2.2.2
R4#sh
mpls ldp neighbor 2.2.2.2 detail
Peer LDP Ident: 2.2.2.2:0; Local LDP Ident
4.4.4.4:0
TCP connection: 2.2.2.2.646 -
4.4.4.4.22816
State: Oper; Msgs sent/rcvd: 62/62;
Downstream; Last TIB rev sent 10
Up time: 00:47:03; UID: 2; Peer Id 1;
LDP discovery sources:
Targeted Hello 4.4.4.4 -> 2.2.2.2,
active, passive;
holdtime: infinite, hello interval:
10000 ms
Addresses bound to peer LDP Ident:
192.1.23.2 2.2.2.2
Peer holdtime: 180000 ms; KA interval:
60000 ms; Peer state: estab
Clients: Dir Adj Client
R1#sh
ip eigrp neighbors
IP-EIGRP
neighbors for process 15
H Address Interface Hold Uptime SRTT
RTO Q Seq
(sec) (ms) Cnt Num
0 192.1.15.5 Se0/0.1 13 00:44:01 11
200 0 3
R1#sh
ip route eigrp
5.0.0.0/32 is subnetted, 1 subnets
D 5.5.5.5 [90/2297856] via 192.1.15.5,
00:44:07, Serial0/0.1
R5#sh
ip eigrp neighbors
IP-EIGRP
neighbors for process 15
H Address Interface Hold Uptime SRTT
RTO Q Seq
(sec) (ms) Cnt Num
0 192.1.15.1 Fa0/0 14 00:44:17 14
200 0 3
R5#sh
ip route eigrp
1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/156160] via 192.1.15.1,
00:44:18, FastEthernet0/0
R1#ping
5.5.5.5 source 1.1.1.1
Type
escape sequence to abort.
Sending
5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
Packet
sent with a source address of 1.1.1.1
!!!!!
Success
rate is 100 percent (5/5), round-trip min/avg/max = 12/12/16 ms
R1#traceroute
5.5.5.5 source 1.1.1.1
Type
escape sequence to abort.
Tracing
the route to 5.5.5.5
1 192.1.15.5 8 msec 12 msec *
R2#sh
mpls forwarding-table
Local Outgoing
Prefix Bytes tag Outgoing
Next Hop
tag tag or VC
or Tunnel Id switched interface
16 Pop tag
3.3.3.3/32 0 Fa0/0 192.1.23.3
17 17
4.4.4.4/32 0 Fa0/0 192.1.23.3
18 Pop tag
192.1.34.0/24 0 Fa0/0 192.1.23.3
19 l2ckt(15) 43506 none
point2point
R2#sh
mpls l2transport summary
Destination
address: 4.4.4.4, total number of vc: 1
0 unknown, 1 up, 0 down, 0 admin down, 0
recovering
1 active vc on MPLS interface Fa0/0
R2#sh
mpls l2transport vc 15
Local
intf Local circuit Dest address VC ID
Status
------------- -------------------------- ---------------
---------- ----------
Se0/0 FR DLCI 100 4.4.4.4 15 UP
R4#sh
mpls l2transport summary
Destination
address: 2.2.2.2, total number of vc: 1
0 unknown, 1 up, 0 down, 0 admin down, 0
recovering
1 active vc on MPLS interface Fa0/0
R4#sh
mpls l2transport vc 15
Local
intf Local circuit Dest address VC ID
Status
------------- -------------------------- ---------------
---------- ----------
Fa0/1 Ethernet 2.2.2.2 15 UP
R4#sh
mpls l2transport binding 15
Destination Address: 2.2.2.2, VC ID: 15
Local Label: 19
Cbit: 1, VC Type: IP, GroupID: 0
MTU: 1500, Interface Desc: n/a
VCCV: CC Type: CW [1], RA [2]
CV Type: LSPV [2]
Remote Label: 19
Cbit: 1, VC Type: IP, GroupID: 0
MTU: 1500, Interface Desc: n/a
VCCV: CC Type: CW [1], RA [2]
CV Type: LSPV [2]
No comments:
Post a Comment