Wednesday, September 2, 2015

Cisco Alcatel BGP Example

Hi all , I just wanted to see how Alcatel-Lucent configuration looks like , so I integrated the image (sros-vm.qcow2) with GNS3 and lapped it up

Ports Configuration

configure card 1 card-type "iom3-xp-b"
configure card 1 mda 1 mda-type "m5-1gb-sfp-b"
configure card 1 mda 2 mda-type "m5-1gb-sfp-b"
admin save


Interfaces Configuration

configure port 1/1/1 no shutdown
configure router interface INTF1 address 192.168.15.5/24
configure router interface INTF1 port 1/1/1

configure port 1/1/2 no shutdown
configure router interface INTF2 address 192.168.25.5/24
configure router interface INTF2 port 1/1/2

configure router interface lo0 address 5.5.5.5/32
configure router interface "lo0" loopback

configure router interface lo1 address 172.16.55.5/32
configure router interface "lo1" loopback

IGP Configuration

configure router ospf router-id 5.5.5.5
configure router ospf area 0.0.0.0 interface "lo0"
exit
configure router ospf area 0.0.0.0 interface "INTF1"

configure port 1/1/1 ethernet mtu 1514

BGP Configuration

A:vRR# configure router bgp
A:vRR>config>router>bgp# info
----------------------------------------------
            group "eBGP"
                description "External-BGP"
                family ipv4
                type external
                neighbor 192.168.25.2
                    peer-as 2
                exit
            exit
            group "iBGP"
                description "Internal-BGP"
                family ipv4
        next-hop-self
                type internal
                peer-as 15
                neighbor 1.1.1.1
                    local-address 5.5.5.5
                exit
            exit
            no shutdown
----------------------------------------------
configure router autonomous-system 15

Static route
configure router static-route 0.0.0.0/0 next-hop 192.168.25.2

R1#sh ip bgp
BGP table version is 1, local router ID is 192.168.15.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *> i 0.0.0.0          192.168.25.2                  100      0 ?


----------------------

Configurations

A:vRR# configure router
A:vRR>config>router# info
----------------------------------------------
#--------------------------------------------------
echo "IP Configuration"
#--------------------------------------------------
        interface "INTF1"
            address 192.168.15.5/24
            port 1/1/1
            no shutdown
        exit
        interface "INTF2"
            address 192.168.25.5/24
            port 1/1/2
            no shutdown
        exit
        interface "lo0"
            address 5.5.5.5/32
            loopback
            no shutdown
        exit
        interface "lo1"
            address 172.16.55.5/32
            loopback
            no shutdown
        exit
        interface "system"
            no shutdown
        exit
        autonomous-system 15
        router-id 5.5.5.5
#--------------------------------------------------
echo "Static Route Configuration"
#--------------------------------------------------
        static-route 0.0.0.0/0 next-hop 192.168.25.2
#--------------------------------------------------
echo "OSPFv2 Configuration"
#--------------------------------------------------
        ospf 5.5.5.5
            area 0.0.0.0
                interface "INTF1"
                    no shutdown
                exit
                interface "lo0"
                    no shutdown
                exit
            exit
        exit
#--------------------------------------------------
echo "Policy Configuration"
#--------------------------------------------------
        policy-options
            begin
            prefix-list "default-only"
                prefix 0.0.0.0/0 exact
            exit
            policy-statement "default-originate"
                entry 10
                    from
                        protocol static
                        prefix-list "default-only"
                        family ipv4
                    exit
                    action accept
                    exit
                exit
                default-action next-policy
                exit
            exit
            commit
        exit
#--------------------------------------------------
echo "BGP Configuration"
#--------------------------------------------------
        bgp
            export "default-originate"
            group "eBGP"
                description "External-BGP"
                family ipv4
                type external
                neighbor 192.168.25.2
                    peer-as 2
                exit
            exit
            group "iBGP"
                description "Internal-BGP"
                family ipv4
                next-hop-self
                type internal
                export "default-originate"
                peer-as 15
                neighbor 1.1.1.1
                    local-address 5.5.5.5
                exit
            exit
            no shutdown
        exit
----------------------------------------------

A:vRR# show router bgp neighbor 1.1.1.1 advertised-routes
===============================================================================
 BGP Router ID:5.5.5.5          AS:15          Local AS:15
===============================================================================
 Legend -
 Status codes  : u - used, s - suppressed, h - history, d - decayed, * - valid
 Origin codes  : i - IGP, e - EGP, ? - incomplete, > - best, b - backup

===============================================================================
BGP IPv4 Routes
===============================================================================
Flag  Network                                            LocalPref   MED
      Nexthop                                            Path-Id     Label
      As-Path
-------------------------------------------------------------------------------
?     0.0.0.0/0                                          100         None
      192.168.25.2                                       None        -
      No As-Path
-------------------------------------------------------------------------------
Routes : 1
===============================================================================

OTV Example


ASR1
hostname ASR1

otv site bridge-domain 1
otv site-identifier 0000.0000.0001

interface Loopback0
 ip address 1.1.1.1 255.255.255.255

interface Overlay1
 no ip address
 otv join-interface GigabitEthernet1
 otv use-adjacency-server 192.168.13.1 unicast-only
 otv adjacency-server unicast-only
 service instance 50 ethernet
  encapsulation dot1q 100
  bridge-domain 200

 service instance 51 ethernet
  encapsulation dot1q 101
  bridge-domain 201

 service instance 52 ethernet
  encapsulation dot1q 33
  bridge-domain 202

interface GigabitEthernet1
 mtu 4470
 ip address 192.168.13.1 255.255.255.0
 negotiation auto

interface GigabitEthernet2
 no ip address
 negotiation auto
 service instance 1 ethernet
  encapsulation untagged
  bridge-domain 1

 service instance 50 ethernet
  encapsulation dot1q 100
  bridge-domain 200

 service instance 51 ethernet
  encapsulation dot1q 101
  bridge-domain 201

 service instance 52 ethernet
  encapsulation dot1q 13
  rewrite ingress tag translate 1-to-1 dot1q 33 symmetric
  bridge-domain 202

router ospf 1
 router-id 1.1.1.1
 network 1.1.1.1 0.0.0.0 area 0
 network 192.168.13.1 0.0.0.0 area 0

ASR2
hostname ASR2

otv site bridge-domain 1
otv site-identifier 0000.0000.0002

interface Loopback0
 ip address 2.2.2.2 255.255.255.255

interface Overlay1
 no ip address
 otv join-interface GigabitEthernet1
 otv use-adjacency-server 192.168.13.1 unicast-only
 service instance 50 ethernet
  encapsulation dot1q 100
  bridge-domain 200

 service instance 51 ethernet
  encapsulation dot1q 101
  bridge-domain 201

 service instance 52 ethernet
  encapsulation dot1q 33
  bridge-domain 202

interface GigabitEthernet1
 mtu 4470
 ip address 192.168.23.2 255.255.255.0
 negotiation auto

interface GigabitEthernet2
 no ip address
 negotiation auto
 service instance 1 ethernet
  encapsulation untagged
  bridge-domain 1

 service instance 50 ethernet
  encapsulation dot1q 100
  bridge-domain 200

 service instance 51 ethernet
  encapsulation dot1q 101
  bridge-domain 201

 service instance 52 ethernet
  encapsulation dot1q 33
  bridge-domain 202

router ospf 1
 router-id 2.2.2.2
 network 2.2.2.2 0.0.0.0 area 0
 network 192.168.23.2 0.0.0.0 area 0

R1
interface Vlan100
 ip address 192.168.100.11 255.255.255.0

interface Vlan101
 ip address 192.168.101.11 255.255.255.0

interface Vlan13
 ip address 192.168.133.1 255.255.255.0

interface FastEthernet1/0
 switchport mode trunk

R2
interface Vlan100
 ip address 192.168.100.12 255.255.255.0

interface Vlan101
 ip address 192.168.101.12 255.255.255.0

interface Vlan33
 ip address 192.168.133.3 255.255.255.0

interface FastEthernet1/0
 switchport mode trunk

Outputs:

R1#ping 192.168.100.12

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.100.12, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/265/692 ms

R1#ping 192.168.101.12

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.101.12, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/115/272 ms

R1#ping 192.168.133.3 source vlan 13

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.133.3, timeout is 2 seconds:
Packet sent with a source address of 192.168.133.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/44/80 ms

ASR1# show otv
Overlay Interface Overlay1
 VPN name                 : None
 VPN ID                   : 1
 State                    : UP
 Fwd-capable              : Yes
 Fwd-ready                : Yes
 AED-Server               : Yes
 Backup AED-Server        : No
 AED Capable              : Yes
 Join interface(s)        : GigabitEthernet1
 Join IPv4 address        : 192.168.13.1
 Tunnel interface(s)      : Tunnel0
 Encapsulation format     : GRE/IPv4
 Site Bridge-Domain       : 1
 Capability               : Unicast-only
 Is Adjacency Server      : Yes
 Adj Server Configured    : Yes
 Prim/Sec Adj Svr(s)      : 192.168.13.1

ASR1# show otv route vlan 100

Codes: BD - Bridge-Domain, AD - Admin-Distance,
       SI - Service Instance, * - Backup Route

OTV Unicast MAC Routing Table for Overlay1

 Inst VLAN BD     MAC Address    AD    Owner  Next Hops(s)
----------------------------------------------------------
 0    100  200    c201.1ea0.0000 40    BD Eng Gi2:SI50
 0    100  200    c202.1ce4.0000 50    ISIS   ASR2

2 unicast routes displayed in Overlay1

----------------------------------------------------------
2 Total Unicast Routes Displayed

ASR1# show otv route vlan 101

Codes: BD - Bridge-Domain, AD - Admin-Distance,
       SI - Service Instance, * - Backup Route

OTV Unicast MAC Routing Table for Overlay1

 Inst VLAN BD     MAC Address    AD    Owner  Next Hops(s)
----------------------------------------------------------
 0    101  201    c201.1ea0.0000 40    BD Eng Gi2:SI51
 0    101  201    c202.1ce4.0000 50    ISIS   ASR2

2 unicast routes displayed in Overlay1

----------------------------------------------------------
2 Total Unicast Routes Displayed

ASR1# show otv route vlan 13
Failed to find VLAN 13 in any Overlay

ASR1# show otv route vlan 33

Codes: BD - Bridge-Domain, AD - Admin-Distance,
       SI - Service Instance, * - Backup Route

OTV Unicast MAC Routing Table for Overlay1

 Inst VLAN BD     MAC Address    AD    Owner  Next Hops(s)
----------------------------------------------------------
 0    33   202    c201.1ea0.0000 40    BD Eng Gi2:SI52
 0    33   202    c202.1ce4.0000 50    ISIS   ASR2

2 unicast routes displayed in Overlay1

----------------------------------------------------------
2 Total Unicast Routes Displayed

ASR2#show otv route vlan 100

Codes: BD - Bridge-Domain, AD - Admin-Distance,
       SI - Service Instance, * - Backup Route

OTV Unicast MAC Routing Table for Overlay1

 Inst VLAN BD     MAC Address    AD    Owner  Next Hops(s)
----------------------------------------------------------
 0    100  200    0000.0c07.ac0a 50    ISIS   ASR1
 0    100  200    c201.1ea0.0000 50    ISIS   ASR1
 0    100  200    c202.1ce4.0000 40    BD Eng Gi2:SI50

3 unicast routes displayed in Overlay1

----------------------------------------------------------
3 Total Unicast Routes Displayed

ASR2#show otv route vlan 101

Codes: BD - Bridge-Domain, AD - Admin-Distance,
       SI - Service Instance, * - Backup Route

OTV Unicast MAC Routing Table for Overlay1

 Inst VLAN BD     MAC Address    AD    Owner  Next Hops(s)
----------------------------------------------------------
 0    101  201    c201.1ea0.0000 50    ISIS   ASR1
 0    101  201    c202.1ce4.0000 40    BD Eng Gi2:SI51

2 unicast routes displayed in Overlay1

----------------------------------------------------------
2 Total Unicast Routes Displayed

ASR2#show otv route vlan 33

Codes: BD - Bridge-Domain, AD - Admin-Distance,
       SI - Service Instance, * - Backup Route

OTV Unicast MAC Routing Table for Overlay1

 Inst VLAN BD     MAC Address    AD    Owner  Next Hops(s)
----------------------------------------------------------
 0    33   202    c201.1ea0.0000 50    ISIS   ASR1
 0    33   202    c202.1ce4.0000 40    BD Eng Gi2:SI52

2 unicast routes displayed in Overlay1

----------------------------------------------------------
2 Total Unicast Routes Displayed


ASR1#show otv vlan
Key:  SI - Service Instance, NA - Non AED, NFC - Not Forward Capable.

Overlay 1 VLAN Configuration Information
 Inst VLAN BD   Auth ED              State                Site If(s)
 0    33   202  *ASR1                active              Gi2:SI52
 0    100  200  *ASR1                active              Gi2:SI50
 0    101  201  *ASR1                active              Gi2:SI51
 Total VLAN(s): 3

ASR2#show otv vlan
Key:  SI - Service Instance, NA - Non AED, NFC - Not Forward Capable.

Overlay 1 VLAN Configuration Information
 Inst VLAN BD   Auth ED              State                Site If(s)
 0    33   202  *ASR2                active              Gi2:SI52
 0    100  200  *ASR2                active              Gi2:SI50
 0    101  201  *ASR2                active              Gi2:SI51
 Total VLAN(s): 3

ip access-list extended CAPTURE
 permit udp host 192.168.13.1 host 192.168.23.2 eq 8472
 permit udp host 192.168.23.2 host 192.168.13.1 eq 8472

monitor capture 1 buffer circular access-list CAPTURE interface g1 both

ASR1#show monitor capture 1 buffer brief
 -------------------------------------------------------------
 #   size   timestamp     source             destination   protocol
 -------------------------------------------------------------
   0  150    0.000000   192.168.13.1     ->  192.168.23.2     UDP
   1 1464    0.133040   192.168.23.2     ->  192.168.13.1     UDP
   2  110    0.907002   192.168.13.1     ->  192.168.23.2     UDP
   3 1464    1.300039   192.168.13.1     ->  192.168.23.2     UDP
   4 1464    4.041990   192.168.13.1     ->  192.168.23.2     UDP
   5 1464    7.110046   192.168.13.1     ->  192.168.23.2     UDP
   6  150    8.562019   192.168.13.1     ->  192.168.23.2     UDP
   7  110    9.149046   192.168.13.1     ->  192.168.23.2     UDP
   8 1464    9.670015   192.168.13.1     ->  192.168.23.2     UDP
   9 1464    9.773006   192.168.23.2     ->  192.168.13.1     UDP
  10 1464   12.425032   192.168.13.1     ->  192.168.23.2     UDP
  11 1464   15.151044   192.168.13.1     ->  192.168.23.2     UDP


Tuesday, July 28, 2015

GNS3 MPLS Xconnect



Setup Components

The setup mainly consists of GNS3 integrated with VmWare workstation that runs CSR1000v

Basic Configuration

CSR1
interface loopback0
ip address 1.1.1.1 255.255.255.255

interface GigabitEthernet1
no shutdown
ip address 192.168.12.1 255.255.255.0
mpls ip

interface GigabitEthernet2
no ip address

mpls label protocol ldp
mpls ldp router-id loopback 0 force

router ospf 1
router-id 1.1.1.1
network 1.1.1.1 0.0.0.0 area 0
network 192.168.12.1 0.0.0.0 area 0

CSR2
interface loopback0
ip address 3.3.3.3 255.255.255.255

interface GigabitEthernet1
no shutdown
ip address 192.168.23.3 255.255.255.0
mpls ip

interface GigabitEthernet2
no ip address

mpls label protocol ldp
mpls ldp router-id loopback 0 force

router ospf 1
router-id 3.3.3.3
network 3.3.3.3 0.0.0.0 area 0
network 192.168.23.3 0.0.0.0 area 0

CE1
interface FastEthernet1/1
switchport trunk encapsulation dot1q
switchport mode ttrunk

CE2
interface FastEthernet1/1
switchport trunk encapsulation dot1q
switchport mode ttrunk


Xconnect Configuration

Under the sub-interface

CSR1
interface GigabitEthernet2
 no ip address
 negotiation auto

interface GigabitEthernet2.15
 encapsulation dot1Q 15
 xconnect 3.3.3.3 15 encapsulation mpls

CSR2
interface GigabitEthernet2
 no ip address
 negotiation auto

interface GigabitEthernet2.15
 encapsulation dot1Q 15
 xconnect 1.1.1.1 15 encapsulation mpls

CE1
vlan 15

interface vlan 15
ip address 192.168.15.3 255.255.255.0

CE2
vlan 15
interface vlan 15
ip address 192.168.15.4 255.255.255.0

Verification

CSR1#show xconnect interface gigabitEthernet 2.15 detail
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
UP pri   ac Gi2.15:15(Eth VLAN)          UP mpls 3.3.3.3:15                   UP
            Interworking: ethernet               Local VC label 19
                                                 Remote VC label 19

CSR1#show xconnect interface gigabitEthernet 2.15 event-trace
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
UP pri   ac Gi2.15:15(Eth VLAN)          UP mpls 3.3.3.3:15                   UP

CE1#ping 192.168.15.4 source vlan 15

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.15.4, timeout is 2 seconds:
Packet sent with a source address of 192.168.15.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/49/104 ms

CSR1#sh l2vpn atom vc vcid 15 detail
pseudowire100001 is up, VC status is up PW type: Ethernet
  Create time: 01:53:07, last status change time: 01:52:53
    Last label FSM state change time: 01:52:49
  Destination address: 3.3.3.3 VC ID: 15
    Output interface: Gi1, imposed label stack {17 19}
    Preferred path: not configured
    Default path: active
    Next hop: 192.168.12.2
  Member of xconnect service Gi2.15-15, group right
    Associated member Gi2.15 is up, status is up
    Interworking type is Ethernet
    Service id: 0x6b000001
  Signaling protocol: LDP, peer 3.3.3.3:0 up
    Targeted Hello: 1.1.1.1(LDP Id) -> 3.3.3.3, LDP is UP
    Graceful restart: not configured and not enabled
    Non stop routing: not configured and not enabled
    PWid FEC (128), VC ID: 15
    Status TLV support (local/remote)         : enabled/supported
      LDP route watch                         : enabled
      Label/status state machine              : established, LruRru
      Local dataplane status received         : No fault
      BFD dataplane status received           : Not sent
      BFD peer monitor status received        : No fault
      Status received from access circuit     : No fault
      Status sent to access circuit           : No fault
      Status received from pseudowire i/f     : No fault
      Status sent to network peer             : No fault
      Status received from network peer       : No fault
      Adjacency status of remote peer         : No fault
  Sequencing: receive disabled, send disabled
  Bindings
    Parameter    Local                          Remote
    ------------ ------------------------------ ------------------------------
    Label        19                             19
    Group ID     0                              0
    Interface
    MTU          1500                           1500
    Control word on (configured: autosense)     on
    PW type      Ethernet                       Ethernet
    VCCV CV type 0x02                           0x02
                   LSPV [2]                       LSPV [2]
    VCCV CC type 0x07                           0x07
                   CW [1], RA [2], TTL [3]       CW [1], RA [2], TTL [3]
    Status TLV   enabled                        supported
  SSO Descriptor: 3.3.3.3/15, local label: 19
  Dataplane:
    SSM segment/switch IDs: 4102/4101 (used), PWID: 1
  Rx Counters
    58 input transit packets, 4925 bytes
    1 drops, 0 seq err
  Tx Counters
    3444 output transit packets, 310987 bytes
    0 drops

Under the pseudowire

Configuration

CSR1
interface pseudowire60
 encapsulation mpls
 neighbor 3.3.3.3 60

interface GigabitEthernet2
 no ip address
 negotiation auto
 service instance 60 ethernet
  encapsulation dot1q 60

l2vpn xconnect context XCONN1
 member GigabitEthernet2 service-instance 60
 member pseudowire60

CSR2
interface pseudowire60
 encapsulation mpls
 neighbor 1.1.1.1 60

interface GigabitEthernet2
 no ip address
 negotiation auto
 service instance 60 ethernet
  encapsulation dot1q 60

l2vpn xconnect context XCONN1
 member GigabitEthernet2 service-instance 60
 member pseudowire60

CE1
vlan 60

interface vlan 60
ip address 172.16.60.3 255.255.255.0

CE2
vlan 60
interface vlan 60
ip address 172.16.60.4 255.255.255.0

Verification

CSR1#sh xconnect interface gigabitEthernet 2 detail
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
UP pri   ac Gi2:60(Eth VLAN)             UP mpls 3.3.3.3:60                   UP
            Interworking: ethernet               Local VC label 21
                                                 Remote VC label 21

CSR1#sh xconnect interface gigabitEthernet 2 event-trace
Legend:    XC ST=Xconnect State  S1=Segment1 State  S2=Segment2 State
  UP=Up       DN=Down            AD=Admin Down      IA=Inactive
  SB=Standby  HS=Hot Standby     RV=Recovering      NH=No Hardware

XC ST  Segment 1                         S1 Segment 2                         S2
------+---------------------------------+--+---------------------------------+--
UP pri   ac Gi2:60(Eth VLAN)             UP mpls 3.3.3.3:60                   UP

CE1#ping 172.16.60.4 source vlan 60

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.60.4, timeout is 2 seconds:
Packet sent with a source address of 172.16.60.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/99/152 ms

CSR1#sh l2vpn atom vc vcid 60 detail
pseudowire60 is up, VC status is up PW type: Ethernet
  Create time: 00:57:37, last status change time: 00:57:17
    Last label FSM state change time: 00:57:17
  Destination address: 3.3.3.3 VC ID: 60
    Output interface: Gi1, imposed label stack {17 21}
    Preferred path: not configured
    Default path: active
    Next hop: 192.168.12.2
  Member of xconnect service XCONN1
    Associated member Gi2 is up, status is up
    Interworking type is Ethernet
    Service id: 0x66000002
  Signaling protocol: LDP, peer 3.3.3.3:0 up
    Targeted Hello: 1.1.1.1(LDP Id) -> 3.3.3.3, LDP is UP
    Graceful restart: not configured and not enabled
    Non stop routing: not configured and not enabled
    PWid FEC (128), VC ID: 60
    Status TLV support (local/remote)         : enabled/supported
      LDP route watch                         : enabled
      Label/status state machine              : established, LruRru
      Local dataplane status received         : No fault
      BFD dataplane status received           : Not sent
      BFD peer monitor status received        : No fault
      Status received from access circuit     : No fault
      Status sent to access circuit           : No fault
      Status received from pseudowire i/f     : No fault
      Status sent to network peer             : No fault
      Status received from network peer       : No fault
      Adjacency status of remote peer         : No fault
  Sequencing: receive disabled, send disabled
  Bindings
    Parameter    Local                          Remote
    ------------ ------------------------------ ------------------------------
    Label        21                             21
    Group ID     0                              0
    Interface
    MTU          1500                           1500
    Control word on (configured: autosense)     on
    PW type      Ethernet                       Ethernet
    VCCV CV type 0x02                           0x02
                   LSPV [2]                       LSPV [2]
    VCCV CC type 0x07                           0x07
                   CW [1], RA [2], TTL [3]       CW [1], RA [2], TTL [3]
    Status TLV   enabled                        supported
  SSO Descriptor: 3.3.3.3/60, local label: 21
  Dataplane:
    SSM segment/switch IDs: 24592/12302 (used), PWID: 3
  Rx Counters
    24 input transit packets, 2381 bytes
    0 drops, 0 seq err
  Tx Counters
    1740 output transit packets, 164359 bytes
    0 drops