Thursday, April 11, 2013

Carrier supporting Carrier (CsC)




Elements

In this example we will configure Carrier supporting Carrier (CsC)
We have two autonomous systems, AS 100 and 200
Our service providers PEs are R3 and R4 which establishes VPNv4 sessions with R2 and R1, which by in turn establishes VPNv4 sessions between themselves
Our customers are R5, R6 and R9 which in turn will provide R8, R7 and R10 with VPN service by establishing VPNv4 in between

Configuration


R1

R1#sh run int pos1/0
interface POS1/0
 ip address 192.1.12.1 255.255.255.0
 encapsulation ppp
 mpls bgp forwarding

R1#sh run int f2/0
interface FastEthernet2/0
 ip address 192.1.13.1 255.255.255.0
 ip router isis 1
 speed 100
 duplex full
 mpls ip

R1#sh run int lo0
interface Loopback0
 ip address 1.1.1.1 255.255.255.255

R1#sh run | sec router isis
router isis 1
 net 49.0001.0000.0000.0001.00
 is-type level-2-only
 passive-interface Loopback0

R1#sh run | sec router bgp
router bgp 100
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 no bgp default route-target filter
 neighbor 3.3.3.3 remote-as 100
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 192.1.12.2 remote-as 200
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor 3.3.3.3 activate
  neighbor 3.3.3.3 send-community both
  neighbor 3.3.3.3 route-reflector-client
  neighbor 3.3.3.3 next-hop-self
  neighbor 192.1.12.2 activate
  neighbor 192.1.12.2 send-community both
 exit-address-family

R2

R2#sh run int pos1/0
interface POS1/0
 ip address 192.1.12.2 255.255.255.0
 encapsulation ppp
 mpls bgp forwarding

R2#sh run int f2/0
interface FastEthernet2/0
 ip address 192.1.24.2 255.255.255.0
 ip router isis 1
 speed 100
 duplex full
 mpls ip

R2#sh run int lo0
interface Loopback0
 ip address 2.2.2.2 255.255.255.255

R2#sh run | sec router isis
router isis 1
 net 49.0002.0000.0000.0002.00
 is-type level-2-only
 passive-interface Loopback0

R2#sh run | sec router bgp
router bgp 200
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 no bgp default route-target filter
 neighbor 4.4.4.4 remote-as 200
 neighbor 4.4.4.4 update-source Loopback0
 neighbor 192.1.12.1 remote-as 100
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor 4.4.4.4 activate
  neighbor 4.4.4.4 send-community both
  neighbor 4.4.4.4 next-hop-self
  neighbor 192.1.12.1 activate
  neighbor 192.1.12.1 send-community both
 exit-address-family

R3

R3#sh run int f1/0
interface FastEthernet1/0
 ip address 192.1.13.3 255.255.255.0
 ip router isis 1
 speed 100
 duplex full
 mpls ip

R3#sh run int f1/1
interface FastEthernet1/1
 vrf forwarding ABC
 ip address 192.1.35.3 255.255.255.0
 speed 100
 duplex full
 mpls ip

R3#sh run int f2/0
interface FastEthernet2/0
 vrf forwarding ABC
 ip address 192.1.36.3 255.255.255.0
 speed 100
 duplex full
 mpls ip

R3#sh run int lo0
Building configuration...
interface Loopback0
 ip address 3.3.3.3 255.255.255.255

R3#sh run | sec router bgp
router bgp 100
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 update-source Loopback0
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community both
 exit-address-family
 !
 address-family ipv4 vrf ABC
  redistribute ospf 1
 exit-address-family

R3#sh run | sec router isis
router isis 1
 net 49.0001.0000.0000.0003.00
 is-type level-2-only
 passive-interface Loopback0

R3#sh run | sec vrf def
vrf definition ABC
 rd 100:1
 route-target export 100:1
 route-target import 100:1
 route-target import 200:1
 !
 address-family ipv4
 exit-address-family

R3#sh run | sec router ospf 1 vrf
router ospf 1 vrf ABC
 router-id 192.1.1.3
 redistribute bgp 100 subnets
 network 192.1.1.3 0.0.0.0 area 0
 network 192.1.35.3 0.0.0.0 area 0
 network 192.1.36.3 0.0.0.0 area 0

R4

R4#sh run int f1/0
interface FastEthernet1/0
 ip address 192.1.24.4 255.255.255.0
 ip router isis 1
 speed 100
 duplex full
 mpls ip

R4#sh run int f1/1
interface FastEthernet1/1
 vrf forwarding ABC
 ip address 192.1.49.4 255.255.255.0
 speed 100
 duplex full
 mpls ip

R4#sh run int lo0
interface Loopback0
 ip address 4.4.4.4 255.255.255.255

R4#sh run | sec router isis
router isis 1
 net 49.0002.0000.0000.0004.00
 is-type level-2-only
 passive-interface Loopback0

R4#sh run | sec router bgp
router bgp 200
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 2.2.2.2 remote-as 200
 neighbor 2.2.2.2 update-source Loopback0
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor 2.2.2.2 activate
  neighbor 2.2.2.2 send-community both
 exit-address-family
 !
 address-family ipv4 vrf ABC
  redistribute ospf 1
 exit-address-family

R4#sh run | sec vrf def
vrf definition ABC
 rd 200:1
 route-target export 200:1
 route-target import 200:1
 route-target import 100:1
 !
 address-family ipv4
 exit-address-family

R5

R5#sh run int f1/0
interface FastEthernet1/0
 ip address 192.1.35.5 255.255.255.0
 speed 100
 duplex full
 mpls ip

R5#sh run int f1/1
interface FastEthernet1/1
 vrf forwarding MSSK
 ip address 192.1.57.5 255.255.255.0
 speed 100
 duplex full

R5#sh run | sec router ospf
router ospf 1
 router-id 192.1.1.5
 network 192.1.1.5 0.0.0.0 area 0
 network 192.1.35.5 0.0.0.0 area 0

R5#sh run | sec router bgp
router bgp 100
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 192.1.1.6 remote-as 100
 neighbor 192.1.1.6 update-source Loopback0
 neighbor 192.1.1.9 remote-as 200
 neighbor 192.1.1.9 ebgp-multihop 255
 neighbor 192.1.1.9 update-source Loopback0
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor 192.1.1.6 activate
  neighbor 192.1.1.6 send-community both
  neighbor 192.1.1.9 activate
  neighbor 192.1.1.9 send-community both
  neighbor 192.1.1.9 next-hop-unchanged
 exit-address-family
 !
 address-family ipv4 vrf MSSK
  redistribute rip
 exit-address-family

R5#sh run | sec router rip
router rip
 !
 address-family ipv4 vrf MSSK
  redistribute bgp 100 metric 5
  network 192.1.57.0
  no auto-summary
  version 2
 exit-address-family

R5#sh run | sec vrf def
vrf definition MSSK
 rd 300:1
 route-target export 300:1
 route-target import 300:1
 !
 address-family ipv4
 exit-address-family

R6

R6#sh run int f1/0
interface FastEthernet1/0
 ip address 192.1.36.6 255.255.255.0
 speed 100
 duplex full
 mpls ip

R6#sh run int f1/1
interface FastEthernet1/1
 vrf forwarding MSSK
 ip address 192.1.68.6 255.255.255.0
 speed 100
 duplex full

R6#sh run int lo0
interface Loopback0
 ip address 192.1.1.6 255.255.255.255

R6#sh run | sec router ospf
router ospf 1
 router-id 192.1.1.6
 network 192.1.1.6 0.0.0.0 area 0
 network 192.1.36.6 0.0.0.0 area 0

R6#sh run | sec router bgp
router bgp 100
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 192.1.1.5 remote-as 100
 neighbor 192.1.1.5 update-source Loopback0
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor 192.1.1.5 activate
  neighbor 192.1.1.5 send-community both
 exit-address-family
 !
 address-family ipv4 vrf MSSK
  redistribute eigrp 68
 exit-address-family

R6#sh run | sec router eigrp
router eigrp 68
 !
 address-family ipv4 vrf MSSK autonomous-system 68
  default-metric 10000 1000 255 1 1500
  redistribute bgp 100
  network 192.1.68.0
 exit-address-family

R6#sh run | sec vrf def
vrf definition MSSK
 rd 300:1
 route-target export 300:1
 route-target import 300:1
 !
 address-family ipv4
 exit-address-family

R7

R7#sh run int f1/0
interface FastEthernet1/0
 ip address 192.1.57.7 255.255.255.0
 speed 100
 duplex full

R7#sh run int lo0
interface Loopback0
 ip address 172.1.1.7 255.255.255.255


R7#sh run | sec router rip
router rip
 version 2
 network 172.1.0.0
 network 192.1.57.0
 no auto-summary

R8

R8#sh run int f1/0
interface FastEthernet1/0
 ip address 192.1.68.8 255.255.255.0
 speed 100
 duplex full

R8#sh run int lo0
interface Loopback0
 ip address 172.1.1.8 255.255.255.255

R8#sh run | sec router eigrp
router eigrp 68
 network 172.1.0.0
 network 192.1.68.0

R9

R9#sh run int f1/0
interface FastEthernet1/0
 ip address 192.1.49.9 255.255.255.0
 speed 100
 duplex full
 mpls ip

R9#sh run int f1/1
interface FastEthernet1/1
 vrf forwarding MSSK
 ip address 192.1.109.9 255.255.255.0
 speed 100
 duplex full

R9#sh run int lo0
interface Loopback0
 ip address 192.1.1.9 255.255.255.255

R9#sh run | sec router bgp
router bgp 200
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 192.1.1.5 remote-as 100
 neighbor 192.1.1.5 ebgp-multihop 255
 neighbor 192.1.1.5 update-source Loopback0
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor 192.1.1.5 activate
  neighbor 192.1.1.5 send-community both
  neighbor 192.1.1.5 next-hop-unchanged
 exit-address-family
 !
 address-family ipv4 vrf MSSK
  redistribute rip
 exit-address-family

R9#sh run | sec router rip
router rip
 !
 address-family ipv4 vrf MSSK
  redistribute bgp 200 metric transparent
  network 192.1.109.0
  no auto-summary
  version 2
 exit-address-family

R9#sh run | sec vrf def
vrf definition MSSK
 rd 300:1
 route-target export 300:1
 route-target import 300:1
 !
 address-family ipv4
 exit-address-family

R10

R10#sh run int f1/0
interface FastEthernet1/0
 ip address 192.1.109.10 255.255.255.0
 speed 100
 duplex full

R10#sh run int lo0
interface Loopback0
 ip address 172.1.1.10 255.255.255.255

R10#sh run | sec router rip
router rip
 version 2
 network 172.1.0.0
 network 192.1.109.0
 no auto-summary

Verification

R1#sh mpls ldp neighbor
    Peer LDP Ident: 3.3.3.3:0; Local LDP Ident 1.1.1.1:0
        TCP connection: 3.3.3.3.53911 - 1.1.1.1.646
        State: Oper; Msgs sent/rcvd: 4750/4742; Downstream
        Up time: 2d21h
        LDP discovery sources:
          FastEthernet2/0, Src IP addr: 192.1.13.3
        Addresses bound to peer LDP Ident:
          192.1.13.3      3.3.3.3         

R1#sh bgp vpnv4 unicast all summary
BGP router identifier 1.1.1.1, local AS number 100
BGP table version is 7, main routing table version 7
6 network entries using 936 bytes of memory
6 path entries using 480 bytes of memory
3/3 BGP path/bestpath attribute entries using 432 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
2 BGP extended community entries using 80 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1952 total bytes of memory
BGP activity 10/4 prefixes, 12/6 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
3.3.3.3         4          100    4111    4115        7    0    0 2d14h           4
192.1.12.2      4          200    4121    4114        7    0    0 2d14h           2

R2#sh mpls ldp neighbor
    Peer LDP Ident: 4.4.4.4:0; Local LDP Ident 2.2.2.2:0
        TCP connection: 4.4.4.4.23586 - 2.2.2.2.646
        State: Oper; Msgs sent/rcvd: 4275/4281; Downstream
        Up time: 2d14h
        LDP discovery sources:
          FastEthernet2/0, Src IP addr: 192.1.24.4
        Addresses bound to peer LDP Ident:
          192.1.24.4      4.4.4.4        

R2#sh bgp vpnv4 unicast all summary
BGP router identifier 2.2.2.2, local AS number 200
BGP table version is 7, main routing table version 7
6 network entries using 936 bytes of memory
6 path entries using 480 bytes of memory
3/3 BGP path/bestpath attribute entries using 432 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
2 BGP extended community entries using 80 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1952 total bytes of memory
BGP activity 10/4 prefixes, 10/4 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
4.4.4.4         4          200    4115    4113        7    0    0 2d14h           2
192.1.12.1      4          100    4115    4123        7    0    0 2d14h           4

R3#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.1.1.6         1   FULL/DR         00:00:36    192.1.36.6      FastEthernet2/0
192.1.1.5         1   FULL/DR         00:00:34    192.1.35.5      FastEthernet1/1

R3#sh isis neighbors

Tag 1:
System Id      Type Interface   IP Address      State Holdtime Circuit Id
R1             L2   Fa1/0       192.1.13.1      UP    22       R3.01             
R3#sh ip route vrf ABC

Routing Table: ABC
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      192.1.1.0/32 is subnetted, 3 subnets
O        192.1.1.5 [110/2] via 192.1.35.5, 2d14h, FastEthernet1/1
O        192.1.1.6 [110/2] via 192.1.36.6, 2d14h, FastEthernet2/0
B        192.1.1.9 [200/0] via 1.1.1.1, 2d14h
      192.1.35.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.1.35.0/24 is directly connected, FastEthernet1/1
L        192.1.35.3/32 is directly connected, FastEthernet1/1
      192.1.36.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.1.36.0/24 is directly connected, FastEthernet2/0
L        192.1.36.3/32 is directly connected, FastEthernet2/0
B     192.1.49.0/24 [200/0] via 1.1.1.1, 2d14h

R4#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.1.1.9         1   FULL/DR         00:00:39    192.1.49.9      FastEthernet1/1

R4#sh isis neighbors

Tag 1:
System Id      Type Interface   IP Address      State Holdtime Circuit Id
R2             L2   Fa1/0       192.1.24.2      UP    22       R4.01             
R4#sh ip route vrf ABC

Routing Table: ABC
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      192.1.1.0/32 is subnetted, 3 subnets
B        192.1.1.5 [200/0] via 2.2.2.2, 2d14h
B        192.1.1.6 [200/0] via 2.2.2.2, 2d14h
O        192.1.1.9 [110/2] via 192.1.49.9, 2d14h, FastEthernet1/1
B     192.1.35.0/24 [200/0] via 2.2.2.2, 2d14h
B     192.1.36.0/24 [200/0] via 2.2.2.2, 2d14h
      192.1.49.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.1.49.0/24 is directly connected, FastEthernet1/1
L        192.1.49.4/32 is directly connected, FastEthernet1/1

R5#sh ip route vrf MSSK

Routing Table: MSSK
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.1.0.0/32 is subnetted, 3 subnets
R        172.1.1.7 [120/1] via 192.1.57.7, 00:00:24, FastEthernet1/1
B        172.1.1.8 [200/156160] via 192.1.1.6, 03:00:28
B        172.1.1.10 [20/1] via 192.1.1.9, 03:01:26
      192.1.57.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.1.57.0/24 is directly connected, FastEthernet1/1
L        192.1.57.5/32 is directly connected, FastEthernet1/1
B     192.1.68.0/24 [200/0] via 192.1.1.6, 03:00:28
B     192.1.109.0/24 [20/0] via 192.1.1.9, 03:01:26

R6#sh ip route vrf MSSK

Routing Table: MSSK
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.1.0.0/32 is subnetted, 3 subnets
B        172.1.1.7 [200/1] via 192.1.1.5, 03:00:46
D        172.1.1.8 [90/156160] via 192.1.68.8, 1d03h, FastEthernet1/1
B        172.1.1.10 [200/1] via 192.1.1.9, 03:00:46
B     192.1.57.0/24 [200/0] via 192.1.1.5, 03:00:46
      192.1.68.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.1.68.0/24 is directly connected, FastEthernet1/1
L        192.1.68.6/32 is directly connected, FastEthernet1/1
B     192.1.109.0/24 [200/0] via 192.1.1.9, 03:00:46

R9#sh ip route vrf MSSK

Routing Table: MSSK
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.1.0.0/32 is subnetted, 3 subnets
B        172.1.1.7 [20/1] via 192.1.1.5, 03:00:58
B        172.1.1.8 [20/0] via 192.1.1.6, 03:00:58
R        172.1.1.10 [120/1] via 192.1.109.10, 00:00:12, FastEthernet1/1
B     192.1.57.0/24 [20/0] via 192.1.1.5, 03:00:58
B     192.1.68.0/24 [20/0] via 192.1.1.6, 03:00:58
      192.1.109.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.1.109.0/24 is directly connected, FastEthernet1/1
L        192.1.109.9/32 is directly connected, FastEthernet1/1

R5#sh bgp vpnv4 unicast all summary
BGP router identifier 192.1.1.5, local AS number 100
BGP table version is 17, main routing table version 17
6 network entries using 936 bytes of memory
6 path entries using 480 bytes of memory
6/6 BGP path/bestpath attribute entries using 864 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
3 BGP extended community entries using 524 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2828 total bytes of memory
BGP activity 46/40 prefixes, 51/45 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.1.1.6       4          100     206     208       17    0    0 03:02:06        2
192.1.1.9       4          200     205     210       17    0    0 03:02:12        2

R6#sh bgp vpnv4 unicast all summary
BGP router identifier 192.1.1.6, local AS number 100
BGP table version is 11, main routing table version 11
6 network entries using 936 bytes of memory
6 path entries using 480 bytes of memory
6/6 BGP path/bestpath attribute entries using 864 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
3 BGP extended community entries using 524 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2828 total bytes of memory
BGP activity 56/50 prefixes, 67/61 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.1.1.5       4          100     208     206       11    0    0 03:02:18        4

R9#sh bgp vpnv4 unicast all summary 
BGP router identifier 192.1.1.9, local AS number 200
BGP table version is 124, main routing table version 124
6 network entries using 936 bytes of memory
6 path entries using 480 bytes of memory
6/6 BGP path/bestpath attribute entries using 864 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
3 BGP extended community entries using 144 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2448 total bytes of memory
BGP activity 46/40 prefixes, 60/54 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.1.1.5       4          100     210     206      124    0    0 03:02:35        4

R7#sh ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.1.0.0/32 is subnetted, 3 subnets
R        172.1.1.8 [120/5] via 192.1.57.5, 00:00:04, FastEthernet1/0
R        172.1.1.10 [120/5] via 192.1.57.5, 00:00:04, FastEthernet1/0
R     192.1.68.0/24 [120/5] via 192.1.57.5, 00:00:04, FastEthernet1/0
R     192.1.109.0/24 [120/5] via 192.1.57.5, 00:00:04, FastEthernet1/0

R7#ping 172.1.1.8 source lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.1.1.8, timeout is 2 seconds:
Packet sent with a source address of 172.1.1.7
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms

R7#traceroute 172.1.1.8 source lo0 numeric
Type escape sequence to abort.
Tracing the route to 172.1.1.8
VRF info: (vrf in name/id, vrf out name/id)
  1 192.1.57.5 4 msec 4 msec 4 msec
  2 192.1.35.3 [MPLS: Labels 21/25 Exp 0] 20 msec 16 msec 16 msec
  3 192.1.68.6 [MPLS: Label 25 Exp 0] 16 msec 12 msec 12 msec
  4 192.1.68.8 16 msec *  16 msec

R7#ping 172.1.1.10 source lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.1.1.10, timeout is 2 seconds:
Packet sent with a source address of 172.1.1.7
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms

R7#traceroute 172.1.1.10 source lo0 numeric
Type escape sequence to abort.
Tracing the route to 172.1.1.10
VRF info: (vrf in name/id, vrf out name/id)
  1 192.1.57.5 4 msec 0 msec 0 msec
  2 192.1.35.3 [MPLS: Labels 18/36 Exp 0] 28 msec 28 msec 32 msec
  3 192.1.13.1 [MPLS: Labels 26/36 Exp 0] 48 msec 32 msec 28 msec
  4 192.1.12.2 [MPLS: Labels 26/36 Exp 0] 40 msec 32 msec 32 msec
  5 192.1.24.4 [MPLS: Labels 16/36 Exp 0] 28 msec 28 msec 28 msec
  6 192.1.109.9 [MPLS: Label 36 Exp 0] 28 msec 24 msec 24 msec
  7 192.1.109.10 28 msec *  28 msec

R8#s ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.1.0.0/32 is subnetted, 3 subnets
D EX     172.1.1.7 [170/514560] via 192.1.68.6, 03:02:44, FastEthernet1/0
D EX     172.1.1.10 [170/514560] via 192.1.68.6, 03:02:44, FastEthernet1/0
D EX  192.1.57.0/24 [170/514560] via 192.1.68.6, 03:02:44, FastEthernet1/0
D EX  192.1.109.0/24 [170/514560] via 192.1.68.6, 03:02:44, FastEthernet1/0

R8#ping 172.1.1.7 source lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.1.1.7, timeout is 2 seconds:
Packet sent with a source address of 172.1.1.8
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms

R8#traceroute 172.1.1.7 source lo0 numeric
Type escape sequence to abort.
Tracing the route to 172.1.1.7
VRF info: (vrf in name/id, vrf out name/id)
  1 192.1.68.6 4 msec 4 msec 4 msec
  2 192.1.36.3 [MPLS: Labels 22/21 Exp 0] 16 msec 16 msec 16 msec
  3 192.1.57.5 [MPLS: Label 21 Exp 0] 16 msec 12 msec 12 msec
  4 192.1.57.7 16 msec *  16 msec

R8#ping 172.1.1.10 source lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.1.1.10, timeout is 2 seconds:
Packet sent with a source address of 172.1.1.8
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/28/32 ms

R8#traceroute 172.1.1.10 source lo0 numeric
Type escape sequence to abort.
Tracing the route to 172.1.1.10
VRF info: (vrf in name/id, vrf out name/id)
  1 192.1.68.6 4 msec 4 msec 4 msec
  2 192.1.36.3 [MPLS: Labels 18/36 Exp 0] 32 msec 28 msec 28 msec
  3 192.1.13.1 [MPLS: Labels 26/36 Exp 0] 32 msec 28 msec 28 msec
  4 192.1.12.2 [MPLS: Labels 26/36 Exp 0] 32 msec 32 msec 28 msec
  5 192.1.24.4 [MPLS: Labels 16/36 Exp 0] 28 msec 32 msec 28 msec
  6 192.1.109.9 [MPLS: Label 36 Exp 0] 28 msec 24 msec 24 msec
  7 192.1.109.10 28 msec *  28 msec

R10#sh ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      172.1.0.0/32 is subnetted, 3 subnets
R        172.1.1.7 [120/2] via 192.1.109.9, 00:00:20, FastEthernet1/0
R        172.1.1.8 [120/1] via 192.1.109.9, 00:00:20, FastEthernet1/0
R     192.1.57.0/24 [120/1] via 192.1.109.9, 00:00:20, FastEthernet1/0
R     192.1.68.0/24 [120/1] via 192.1.109.9, 00:00:20, FastEthernet1/0

R10#ping 172.1.1.7 source lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.1.1.7, timeout is 2 seconds:
Packet sent with a source address of 172.1.1.10
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms

R10#traceroute 172.1.1.7 source lo0 numeric
Type escape sequence to abort.
Tracing the route to 172.1.1.7
VRF info: (vrf in name/id, vrf out name/id)
  1 192.1.109.9 4 msec 4 msec 4 msec
  2 192.1.49.4 [MPLS: Labels 19/21 Exp 0] 36 msec 28 msec 28 msec
  3 192.1.24.2 [MPLS: Labels 22/21 Exp 0] 28 msec 28 msec 32 msec
  4 192.1.12.1 [MPLS: Labels 22/21 Exp 0] 48 msec 32 msec 28 msec
  5 192.1.13.3 [MPLS: Labels 22/21 Exp 0] 32 msec 28 msec 28 msec
  6 192.1.57.5 [MPLS: Label 21 Exp 0] 28 msec 24 msec 24 msec
  7 192.1.57.7 32 msec *  28 msec

R10#ping 172.1.1.8 source lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.1.1.8, timeout is 2 seconds:
Packet sent with a source address of 172.1.1.10
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/29/32 ms

R10#traceroute 172.1.1.8 source lo0 numeric
Type escape sequence to abort.
Tracing the route to 172.1.1.8
VRF info: (vrf in name/id, vrf out name/id)
  1 192.1.109.9 4 msec 4 msec 4 msec
  2 192.1.49.4 [MPLS: Labels 20/25 Exp 0] 28 msec 32 msec 28 msec
  3 192.1.24.2 [MPLS: Labels 23/25 Exp 0] 28 msec 32 msec 28 msec
  4 192.1.12.1 [MPLS: Labels 23/25 Exp 0] 28 msec 32 msec 28 msec
  5 192.1.13.3 [MPLS: Labels 21/25 Exp 0] 32 msec 28 msec 28 msec
  6 192.1.68.6 [MPLS: Label 25 Exp 0] 28 msec 24 msec 24 msec
  7 192.1.68.8 32 msec *  28 msec