Monday, April 1, 2013

MPLS L3VPN IOS XR





Elements


       In this example PE routers are IOS XR based and the rest of the devices are IOS based router, ISIS will be the IGP inside the MPLS backbone and OSPF is the PE-CE routing protocol.

R7 and R8 will be our CE routers and R3 will act as the P router

Configuration


R7

R7#sh run int f0/0
interface FastEthernet0/0
 ip address 192.1.17.7 255.255.255.0
 duplex full
 speed 100

R7#sh run int lo0
interface Loopback0
 ip address 7.7.7.7 255.255.255.255

router ospf 100
router-id 7.7.7.7
network 7.7.7.7 0.0.0.0 area 0
network 192.1.17.7 0.0.0.0 area 0

XR1

vrf MSSK
 address-family ipv4 unicast
  import route-target
   100:1
  !
  export route-target
   100:1
  !
 !
interface Loopback0
 ipv4 address 1.1.1.1 255.255.255.255

interface GigabitEthernet0/1/0/0.13
 ipv4 address 192.1.13.1 255.255.255.0
 dot1q vlan 13

interface GigabitEthernet0/1/0/0.17
 vrf MSSK
 ipv4 address 192.1.17.1 255.255.255.0
 dot1q vlan 17

router isis 1 à You have to configure ID
 is-type level-2-only
 net 49.0001.0000.0000.0001.00
 address-family ipv4 unicast
  mpls traffic-eng level-2-only
 !
 interface Loopback0
  address-family ipv4 unicast
  !
interface GigabitEthernet0/1/0/0.13
  address-family ipv4 unicast

router ospf 100
 vrf MSSK
  redistribute bgp 100
  area 0
   interface GigabitEthernet0/1/0/0.17

router bgp 100
 address-family vpnv4 unicast
 !
 neighbor 3.3.3.3
  remote-as 100
  update-source Loopback0
  address-family vpnv4 unicast
  !
 !
 vrf MSSK
  rd 100:1
  address-family ipv4 unicast
   redistribute ospf 100

mpls ldp
 router-id 1.1.1.1
interface GigabitEthernet0/1/0/0.13
!

R3

R3#sh run int f0/0
interface FastEthernet0/0
ip address 192.1.13.3 255.255.255.0
duplex full
speed 100
mpls ip

R3#sh run int f0/1
interface FastEthernet0/1
ip address 192.1.23.3 255.255.255.0
duplex full
speed 100
mpls ip

R3#sh run int lo0
interface Loopback0
 ip address 3.3.3.3 255.255.255.255

router isis
net 49.0001.0000.0000.0003.00
passive-interface loopback0
is-type level-2

router bgp 100
no bgp default ipv4-unicast
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source lo0
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source lo0

address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 1.1.1.1 route-refelctor-client
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 2.2.2.2 route-refelctor-client

XR2

vrf MSSK
 address-family ipv4 unicast
  import route-target
   100:1
  !
  export route-target
   100:1
  !
 !

interface Loopback0
 ipv4 address 2.2.2.2 255.255.255.255

interface GigabitEthernet0/4/0/0.23
 ipv4 address 192.1.23.2 255.255.255.0
 dot1q vlan 23
!
interface GigabitEthernet0/4/0/0.28
 vrf MSSK
 ipv4 address 192.1.28.2 255.255.255.0
 dot1q vlan 28

router isis 1
 is-type level-2-only
 net 49.0001.0000.0000.0002.00
 address-family ipv4 unicast
  mpls traffic-eng level-2-only
 !
 interface Loopback0
  address-family ipv4 unicast
  !
interface GigabitEthernet0/4/0/0.23
  address-family ipv4 unicast
  !
router ospf 100
 vrf MSSK
  redistribute bgp 100
  area 0
   interface GigabitEthernet0/4/0/0.28
   !
 router bgp 100
 address-family vpnv4 unicast
 !
 neighbor 3.3.3.3
  remote-as 100
  update-source Loopback0
  address-family vpnv4 unicast
  !
 !
 vrf MSSK
  rd 100:1
  address-family ipv4 unicast
   redistribute ospf 100
  !
 ! mpls ldp
 router-id 2.2.2.2
interface GigabitEthernet0/4/0/0.23

R8

R8#sh run int f0/0
interface FastEthernet0/0
 ip address 192.1.28.8 255.255.255.0
 duplex full
 speed 100

R8#sh run int lo0
interface Loopback0
 ip address 8.8.8.8 255.255.255.255

router ospf 100
router-id 8.8.8.8
network 8.8.8.8 0.0.0.0 area 0
network 192.1.28.8 0.0.0.0 area 0

No comments: