Wednesday, June 19, 2013

Frame-relay L2TPv3




Issue

In this example we will configure L2TPv3 between our PEs (R2, R3) in order to achieve IPv4 and IPv6 connectivity between our CEs (R1, R4)
Routing protocol is use between the CEs is RIP version 2

Configuration

R1

R1#sh run int lo0
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 ipv6 address 2001::1/128
 ipv6 rip RIPng enable

R1#sh run int s1/0
interface Serial1/0
 ip address 192.1.14.1 255.255.255.0
 encapsulation frame-relay
 ipv6 address 2001:192:14::1/64
 ipv6 rip RIPng enable
 serial restart-delay 0
 frame-relay map ipv6 2001:192:14::4 101 broadcast
 frame-relay map ipv6 FE80::C804:13FF:FEA2:0 101 broadcast
 frame-relay map ip 192.1.14.4 101 broadcast
 frame-relay lmi-type ansi

R1#sh run | sec router rip
router rip
 version 2
 network 1.0.0.0
 network 192.1.14.0
 no auto-summary
ipv6 router rip RIPng

R2

R2#sh run int lo0
interface Loopback0
 ip address 2.2.2.2 255.255.255.255

R2#sh run int f2/0
interface FastEthernet2/0
 ip address 192.1.23.2 255.255.255.0
 speed 100
 duplex full

R2#sh run int s1/0
interface Serial1/0
 no ip address
 encapsulation frame-relay

R2#sh run | sec pse
pseudowire-class MSSK
 encapsulation l2tpv3
 ip local interface Loopback0

R2#sh run | sec connect
connect FR Serial1/0 202 l2transport
 xconnect 3.3.3.3 14 pw-class MSSK

R2#sh run | sec router ospf
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 192.1.23.2 0.0.0.0 area 0

R3

R3#sh run int lo0
interface Loopback0
 ip address 3.3.3.3 255.255.255.255

R3#sh run int f2/0
interface FastEthernet2/0
 ip address 192.1.23.3 255.255.255.0
 speed 100
 duplex full

R3#sh run int ser1/0
interface Serial1/0
 no ip address
 encapsulation frame-relay

R3#sh run | sec pse
pseudowire-class MSSK
 encapsulation l2tpv3
 ip local interface Loopback0
R3#sh run | sec connect
connect FR Serial1/0 303 l2transport
 xconnect 2.2.2.2 14 pw-class MSSK
 !
R3#sh run | sec router ospf
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 192.1.23.3 0.0.0.0 area 0

R4

R4#sh run int lo0
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 ipv6 address 2001::4/128
 ipv6 rip RIPng enable

R4#sh run int s1/0
interface Serial1/0
 ip address 192.1.14.4 255.255.255.0
 encapsulation frame-relay
 ipv6 address 2001:192:14::4/64
 ipv6 rip RIPng enable
 serial restart-delay 0
 frame-relay map ipv6 2001:192:14::1 404 broadcast
 frame-relay map ipv6 FE80::C801:13FF:FE92:0 404 broadcast
 frame-relay map ip 192.1.14.1 404 broadcast
 frame-relay lmi-type ansi

R4#sh run | sec router rip
router rip
 version 2
 network 4.0.0.0
 network 192.1.14.0
 no auto-summary
ipv6 router rip RIPng

Note:
When dealing with frame-relay and IPv6, we have to configure mapping to the link local address as well which is extracted (and can be hardcoded) from the below

R1#sh ipv6 interface serial 1/0 | inc link
  IPv6 is enabled, link-local address is FE80::C801:13FF:FE92:0
  No Virtual link-local address(es):

R4#sh ipv6 int s1/0 | inc link
  IPv6 is enabled, link-local address is FE80::C804:13FF:FEA2:0
  No Virtual link-local address(es):



Verification

R1#sh frame-relay map
Serial1/0 (up): ipv6 2001:192:14::4 dlci 101(0x65,0x1850), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ipv6 FE80::C804:13FF:FEA2:0 dlci 101(0x65,0x1850), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 192.1.14.4 dlci 101(0x65,0x1850), static,
              broadcast,
              CISCO, status defined, active

R1#sh ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      4.0.0.0/32 is subnetted, 1 subnets
R        4.4.4.4 [120/1] via 192.1.14.4, 00:00:00, Serial1/0

R1#ping 4.4.4.4         

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/19/24 ms

R1#traceroute 4.4.4.4 numeric

Type escape sequence to abort.
Tracing the route to 4.4.4.4

  1 192.1.14.4 16 msec *  16 msec

R1#sh ipv6 route rip
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2
       IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external
       ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
R   2001::4/128 [120/2]
     via FE80::C804:13FF:FEA2:0, Serial1/0

R1#ping 2001::4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/19/28 ms

R1#traceroute 2001::4   

Type escape sequence to abort.
Tracing the route to 2001::4

  1 2001:192:14::4 12 msec 16 msec 16 msec

R4#sh frame-relay map
Serial1/0 (up): ipv6 2001:192:14::1 dlci 404(0x194,0x6440), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ipv6 FE80::C801:13FF:FE92:0 dlci 404(0x194,0x6440), static,
              broadcast,
              CISCO, status defined, active
Serial1/0 (up): ip 192.1.14.1 dlci 404(0x194,0x6440), static,
              broadcast,
              CISCO, status defined, active

R4#sh ip route rip
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
R        1.1.1.1 [120/1] via 192.1.14.1, 00:00:12, Serial1/0

R4#ping 1.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/18/20 ms

R4#traceroute 1.1.1.1 numeric

Type escape sequence to abort.
Tracing the route to 1.1.1.1

  1 192.1.14.1 16 msec *  16 msec

R4#sh ipv6 route rip
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2
       IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external
       ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
R   2001::1/128 [120/2]
     via FE80::C801:13FF:FE92:0, Serial1/0

R4#ping 2001::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/16/20 ms

R4#traceroute 2001::1

Type escape sequence to abort.
Tracing the route to 2001::1

  1 2001:192:14::1 12 msec 12 msec 16 msec

R2#show l2tp tunnel summary

L2TP Tunnel Information Total tunnels 1 sessions 1

LocTunID   RemTunID   Remote Name   State  Remote Address  Sessn L2TP Class/
                                                           Count VPDN Group
4166035714 3475960279 R3            est    3.3.3.3         1     l2tp_default_cl

R2#show l2tp session brief

L2TP Session Information Total tunnels 1 sessions 1

LocID      TunID      Peer-address    State     Username, Intf/                
                                      sess/cir  Vcid, Circuit                  
3186344884 4166035714 3.3.3.3         est,UP    14, Se1/0:202

R3#show l2tp tunnel summary

L2TP Tunnel Information Total tunnels 1 sessions 1

LocTunID   RemTunID   Remote Name   State  Remote Address  Sessn L2TP Class/
                                                           Count VPDN Group
3475960279 4166035714 R2            est    2.2.2.2         1     l2tp_default_cl

R3#show l2tp session brief

L2TP Session Information Total tunnels 1 sessions 1

LocID      TunID      Peer-address    State     Username, Intf/                
                                      sess/cir  Vcid, Circuit                  
1379301905 3475960279 2.2.2.2         est,UP    14, Se1/0:303

No comments: