Sunday, October 7, 2012

MPLS L3 VPN With IPv6



Issue

In this Lab we will configure traditional MPLS L3 VPN , software image in use is c3725-adventerprisek9-mz.124-18 , in addition we will configure IPv6 addressing between PEs and CEs and transport over the IPv4 MPLS backbone , so called 6PE and 6VPE

Basic Configuration

6PE

CE1

CE1#sh run int f0/0
interface FastEthernet0/0
 ip address 192.1.12.1 255.255.255.0
 speed 100
 full-duplex

CE1#sh run int lo0
interface Loopback0
 ip address 1.1.1.1 255.255.255.255

CE1#sh run | sec ip route
ip route 0.0.0.0 0.0.0.0 192.1.12.2

PE1

PE1#sh run int f0/0
interface FastEthernet0/0
 ip vrf forwarding MSSK
 ip address 192.1.12.2 255.255.255.0
 speed 100
 full-duplex

PE1#sh run int f0/1
interface FastEthernet0/1
 ip address 192.1.23.2 255.255.255.0
 ip ospf 1 area 0
 speed 100
 full-duplex
 mpls ip

PE1#sh run int lo0
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 ip ospf 1 area 0

PE1#sh run | sec router bgp
router bgp 123
 no synchronization
 bgp log-neighbor-changes
 neighbor 4.4.4.4 remote-as 123
 neighbor 4.4.4.4 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 4.4.4.4 activate
  neighbor 4.4.4.4 send-community both
 exit-address-family
 !
 address-family ipv4 vrf MSSK
  redistribute connected
  redistribute static
  no synchronization
 exit-address-family

PE1#sh run | sec ip route
ip route vrf MSSK 1.1.1.1 255.255.255.255 192.1.12.1

ip vrf MSSK
 rd 100:1
 route-target export 100:1
 route-target import 100:1

P

P#sh run int f0/0
interface FastEthernet0/0
 ip address 192.1.23.3 255.255.255.0
 ip ospf 1 area 0
 speed 100
 full-duplex
 mpls ip


P#sh run int f0/1
interface FastEthernet0/1
 ip address 192.1.34.3 255.255.255.0
 ip ospf 1 area 0
 speed 100
 full-duplex
 mpls ip

P#sh run int lo0
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 ip ospf 1 area 0

PE2

PE2#sh run int f0/0
interface FastEthernet0/0
 ip address 192.1.34.4 255.255.255.0
 ip ospf 1 area 0
 speed 100
 full-duplex
 mpls ip

PE2#sh run int f0/1
interface FastEthernet0/1
 ip vrf forwarding MSSK
 ip address 192.1.45.4 255.255.255.0
 speed 100
 full-duplex

PE2#sh run int lo0
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 ip ospf 1 area 0

PE2#sh run | sec router bgp
router bgp 123
 no synchronization
 bgp log-neighbor-changes
 neighbor 2.2.2.2 remote-as 123
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 2.2.2.2 activate
  neighbor 2.2.2.2 send-community both
 exit-address-family
 !
address-family ipv4 vrf MSSK
  redistribute connected
  redistribute static
  no synchronization
 exit-address-family

PE2#sh run | sec ip route
ip route vrf MSSK 5.5.5.5 255.255.255.255 192.1.45.5

ip vrf MSSK
 rd 100:1
 route-target export 100:1
 route-target import 100:1

CE2

CE2#sh run int f0/0
interface FastEthernet0/0
 ip address 192.1.45.5 255.255.255.0
 speed 100
 full-duplex

CE2#sh run int lo0
interface Loopback0
 ip address 5.5.5.5 255.255.255.255

CE2#sh run | sec ip route
ip route 0.0.0.0 0.0.0.0 192.1.45.4

Verification

Now as an IPv4 MPLS L3 VPN, we already know the details needed to configure MPLS L3 VPN in addition to the below commands to ensure appropriate LDP peering on P and PE routers

mpls label protocol ldp
mpls ldp router-id loopback 0 force
mpls ip (from interface configuration mode)

The CE-PE routing protocol is static, we defined a static route from R2 towards R1’s loopback 0 interface and from R4 towards R4 loopback 0 interface and we redistributed that under the address-family ipv4 vrf {Name}

Below are some show commands to verify the connectivity between CEs and the operational parameters involved


CE1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.1.12.2 to network 0.0.0.0

C    192.1.12.0/24 is directly connected, FastEthernet0/0
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
S*   0.0.0.0/0 [1/0] via 192.1.12.2


CE1#ping 5.5.5.5 source loopback 0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/19/24 ms

PE1#sh ip route vrf MSSK

Routing Table: MSSK
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.1.12.0/24 is directly connected, FastEthernet0/0
     1.0.0.0/32 is subnetted, 1 subnets
S       1.1.1.1 [1/0] via 192.1.12.1
B    192.1.45.0/24 [200/0] via 4.4.4.4, 07:57:39
     5.0.0.0/32 is subnetted, 1 subnets
B       5.5.5.5 [200/0] via 4.4.4.4, 07:57:30

PE1#sh bgp vpnv4 unicast all
BGP table version is 31, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf MSSK)
*> 1.1.1.1/32       192.1.12.1               0         32768 ?
*>i5.5.5.5/32       4.4.4.4                  0    100      0 ?
*> 192.1.12.0       0.0.0.0                  0         32768 ?
*>i192.1.45.0       4.4.4.4                  0    100      0 ?

PE1#sh bgp vpnv4 unicast all neighbors 4.4.4.4 advertised-routes
BGP table version is 31, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf MSSK)
*> 1.1.1.1/32       192.1.12.1               0         32768 ?
*> 192.1.12.0       0.0.0.0                  0         32768 ?

Total number of prefixes 2

P#sh mpls ldp neighbor
    Peer LDP Ident: 2.2.2.2:0; Local LDP Ident 3.3.3.3:0
        TCP connection: 2.2.2.2.646 - 3.3.3.3.33629
        State: Oper; Msgs sent/rcvd: 573/577; Downstream
        Up time: 08:13:14
        LDP discovery sources:
          FastEthernet0/0, Src IP addr: 192.1.23.2
        Addresses bound to peer LDP Ident:
          192.1.23.2      2.2.2.2        
    Peer LDP Ident: 4.4.4.4:0; Local LDP Ident 3.3.3.3:0
        TCP connection: 4.4.4.4.40116 - 3.3.3.3.646
        State: Oper; Msgs sent/rcvd: 573/574; Downstream
        Up time: 08:12:56
        LDP discovery sources:
          FastEthernet0/1, Src IP addr: 192.1.34.4
        Addresses bound to peer LDP Ident:
          192.1.34.4      4.4.4.4      

PE2#sh ip route vrf MSSK

Routing Table: MSSK
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

B    192.1.12.0/24 [200/0] via 2.2.2.2, 08:00:13
     1.0.0.0/32 is subnetted, 1 subnets
B       1.1.1.1 [200/0] via 2.2.2.2, 08:00:01
C    192.1.45.0/24 is directly connected, FastEthernet0/1
     5.0.0.0/32 is subnetted, 1 subnets
S       5.5.5.5 [1/0] via 192.1.45.5

CE2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.1.45.4 to network 0.0.0.0

C    192.1.45.0/24 is directly connected, FastEthernet0/0
     5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback0
S*   0.0.0.0/0 [1/0] via 192.1.45.4

CE2#ping 1.1.1.1 source loopback 0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 5.5.5.5
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms

As we can see that connectivity is achieved between CEs loopbacks

Now let us configure IPv6 addressing on the links between CE1-PE1, CE2-PE2

CE1, CE2, PE1, PE2

ipv6 unicast-routing
ipv6 cef

CE1

interface FastEthernet0/0
 ipv6 address 2001:DB8:12::1/64

interface Loopback0
ipv6 address 2001:DB8::1/128

PE1

interface FastEthernet0/0
ipv6 address 2001:DB8:12::2/64

PE2

interface FastEthernet0/1
ipv6 address 2001:DB8:45::4/64

CE2

interface FastEthernet0/0
ipv6 address 2001:DB8:45::5/64

interface Loopback0
 ipv6 address 2001:DB8::5/128


Now let us configure default routes on CE1 and CE2 pointing towards PE1 and PE2 respectively

CE1
ipv6 route ::/0 2001:DB8:12::2

CE2
ipv6 route ::/0 2001:DB8:45::4

And from the PEs we will configure static routes back to the CEs loopback interfaces in order to reach and redistribute into the BGP address family to transport to the other end

PE1
ipv6 route 2001:DB8::1/128 2001:DB8:12::1

PE2
ipv6 route 2001:DB8::5/128 2001:DB8:45::5

Now, the important part is how we will import these prefixes and how they will be transported

PE1
router bgp 123
address-family ipv6
  neighbor 4.4.4.4 activate (4.4.4.4 is the remote 6PE )
  neighbor 4.4.4.4 send-label  (Send Labels Along with IPv6 Prefixes by Means of MP-BGP)
  redistribute connected
  redistribute static (To transport the loopback 0 interface of CE1)
  no synchronization
 exit-address-family

PE2
router bgp 123
 address-family ipv6
  neighbor 2.2.2.2 activate
  neighbor 2.2.2.2 send-label
  redistribute connected
  redistribute static
  no synchronization
 exit-address-family

CE1#sh ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S   ::/0 [1/0]
     via 2001:DB8:12::2
LC  2001:DB8::1/128 [0/0]
     via ::, Loopback0
C   2001:DB8:12::/64 [0/0]
     via ::, FastEthernet0/0
L   2001:DB8:12::1/128 [0/0]
     via ::, FastEthernet0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

CE1#ping 2001:DB8::5 source loopback 0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8::5, timeout is 2 seconds:
Packet sent with a source address of 2001:DB8::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/18/20 ms


PE1#sh bgp ipv6 unicast
BGP table version is 5, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2001:DB8::1/128  2001:DB8:12::1           0         32768 ?
*>i2001:DB8::5/128  ::FFFF:4.4.4.4           0    100      0 ?
*> 2001:DB8:12::/64 ::                       0         32768 ?
*>i2001:DB8:45::/64 ::FFFF:4.4.4.4           0    100      0 ?

PE1#sh bgp ipv6 unicast summary
BGP router identifier 2.2.2.2, local AS number 123
BGP table version is 5, main routing table version 5
4 network entries using 596 bytes of memory
4 path entries using 304 bytes of memory
5/2 BGP path/bestpath attribute entries using 620 bytes of memory
1 BGP extended community entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1544 total bytes of memory
BGP activity 9/1 prefixes, 17/9 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
4.4.4.4         4   123     531     532        5    0    0 07:58:45        2


PE2#sh bgp ipv6 unicast neighbors 4.4.4.4 advertised-routes
BGP table version is 5, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2001:DB8::1/128  2001:DB8:12::1           0         32768 ?
*> 2001:DB8:12::/64 ::                       0         32768 ?

Total number of prefixes 2


PE2#sh bgp ipv6 unicast neighbors 2.2.2.2 advertised-routes
BGP table version is 5, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2001:DB8::5/128  2001:DB8:45::5           0         32768 ?
*> 2001:DB8:45::/64 ::                       0         32768 ?

Total number of prefixes 2

PE2#sh bgp ipv6 unicast summary
BGP router identifier 4.4.4.4, local AS number 123
BGP table version is 5, main routing table version 5
4 network entries using 596 bytes of memory
4 path entries using 304 bytes of memory
5/2 BGP path/bestpath attribute entries using 620 bytes of memory
1 BGP extended community entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1544 total bytes of memory
BGP activity 9/1 prefixes, 18/10 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4   123     533     533        5    0    0 07:59:39        2

PE2#sh bgp ipv6 unicast
BGP table version is 5, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i2001:DB8::1/128  ::FFFF:2.2.2.2           0    100      0 ?
*> 2001:DB8::5/128  2001:DB8:45::5           0         32768 ?
*>i2001:DB8:12::/64 ::FFFF:2.2.2.2           0    100      0 ?
*> 2001:DB8:45::/64 ::                       0         32768 ?

CE2#sh ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S   ::/0 [1/0]
     via 2001:DB8:45::4
LC  2001:DB8::5/128 [0/0]
     via ::, Loopback0
C   2001:DB8:45::/64 [0/0]
     via ::, FastEthernet0/0
L   2001:DB8:45::5/128 [0/0]
     via ::, FastEthernet0/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

R5#ping 2001:DB8::1 source loopback 0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8::1, timeout is 2 seconds:
Packet sent with a source address of 2001:DB8::5
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/17/20 ms

R2#sh mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop   
tag    tag or VC   or Tunnel Id      switched   interface             
16     Aggregate   192.1.12.0/24[V]  936                               
17     Pop tag     3.3.3.3/32        0          Fa0/1      192.1.23.3  
18     17          4.4.4.4/32        0          Fa0/1      192.1.23.3  
19     Untagged    1.1.1.1/32[V]     1140       Fa0/0      192.1.12.1  
20     Pop tag     192.1.34.0/24     0          Fa0/1      192.1.23.3  
21     Aggregate   2001:DB8:12::/64  3720                               
22     Untagged    2001:DB8::1/128   2166       Fa0/0      2001:DB8:12::1

R3#sh mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop   
tag    tag or VC   or Tunnel Id      switched   interface              
16     Pop tag     2.2.2.2/32        75394      Fa0/0      192.1.23.2  
17     Pop tag     4.4.4.4/32        50070      Fa0/1      192.1.34.4

R4#sh mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop   
tag    tag or VC   or Tunnel Id      switched   interface             
16     16          2.2.2.2/32        0          Fa0/0      192.1.34.3  
17     Pop tag     3.3.3.3/32        0          Fa0/0      192.1.34.3  
18     Pop tag     192.1.23.0/24     0          Fa0/0      192.1.34.3  
19     Aggregate   192.1.45.0/24[V]  0                                 
20     Untagged    5.5.5.5/32[V]     2166       Fa0/1      192.1.45.5  
21     Aggregate   2001:DB8:45::/64  3740                              
22     Untagged    2001:DB8::5/128   2466       Fa0/1      2001:DB8:45::5

As we can see from the outputs above that CE1 can reach CE2 and vice versa, the routes on the PEs as can be noted are in the global routing table and not in a VRF, as well we did not configure P to support IPv6 as well there are no label bindings to an IPv6 addresses in the MPLS forwarding table of the P router, we only needed the PEs to activate the session between their loopbacks and create the IPv6 address-family

This is the concept of 6PE, IPv6 VPN routes are installed in the global routing table, if we wanted to configure VRF to contain these routes, we have to configure a new address family (address-family vpnv6) between the PEs and we have to configure our VRF using the vrf definition {} command which supports both IPv4 and IPv6 (multiprotocol VRF) , as well we activate the type of address family under the vrf definition {} configuration mode

Starting from IOS 12.4(20)T (and 12.2(33)Sxx) the new command "vrf definition" was introduced.

6VPE

Now assuming we have changed our version to 12.4(20) and with same IPv4 configuration listed above, let us go through the configuration of 6VPE

PE1

vrf definition MSSK
 rd 100:1
 route-target export 100:1
 route-target import 100:1
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family

router bgp 123
address-family vpnv6
  neighbor 4.4.4.4 activate
  neighbor 4.4.4.4 send-community both
 exit-address-family

address-family ipv6 vrf MSSK
  redistribute connected
  redistribute static
  no synchronization
 exit-address-family

interface FastEthernet1/0
 vrf forwarding MSSK

PE2

vrf definition MSSK
 rd 100:1
 route-target export 100:1
 route-target import 100:1
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family

router bgp 123
address-family vpnv6
  neighbor 2.2.2.2 activate
  neighbor 2.2.2.2 send-community both
 exit-address-family
address-family ipv6 vrf MSSK
  redistribute connected
  redistribute static
  no synchronization
 exit-address-family

interface FastEthernet1/1
 vrf forwarding MSSK

If we tried to configure the vrf forwarding under the interface without specifying the address-family (either IPv4 or IPv6) under the vrf definition configuration mode, we will be prompted for an error

PE2(config-if)#ipv6 address 2001:db8:45::4/64
%FastEthernet1/1 is linked to a VRF. Enable IPv6 on that VRF first.

CE1#sh ipv6 route
IPv6 Routing Table - Default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S   ::/0 [1/0]
     via 2001:DB8:12::2
LC  2001:DB8::1/128 [0/0]
     via Loopback0, receive
C   2001:DB8:12::/64 [0/0]
     via FastEthernet1/0, directly connected
L   2001:DB8:12::1/128 [0/0]
     via FastEthernet1/0, receive
L   FF00::/8 [0/0]
     via Null0, receive


CE1#ping 2001:db8::5 source loopback 0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8::5, timeout is 2 seconds:
Packet sent with a source address of 2001:DB8::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms

PE1#sh bgp vpnv6 unicast all summary
BGP router identifier 2.2.2.2, local AS number 123
BGP table version is 12, main routing table version 12
4 network entries using 720 bytes of memory
4 path entries using 384 bytes of memory
3/2 BGP path/bestpath attribute entries using 444 bytes of memory
1 BGP extended community entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 2) using 32 bytes of memory
BGP using 1604 total bytes of memory
BGP activity 8/0 prefixes, 12/4 paths, scan interval 15 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
4.4.4.4         4   123     488     486       12    0    0 07:34:15        2

PE1#sh bgp vpnv6 unicast all neighbors 4.4.4.4 advertised-routes
BGP table version is 12, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf MSSK)
*> 2001:DB8::1/128  ::                       0         32768 ?
*> 2001:DB8:12::/64 ::                       0         32768 ?

Total number of prefixes 2

PE1#sh bgp vpnv6 unicast all neighbors 4.4.4.4 routes           
BGP table version is 12, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf MSSK)
*>i2001:DB8::5/128  ::FFFF:4.4.4.4           0    100      0 ?
*>i2001:DB8:45::/64 ::FFFF:4.4.4.4           0    100      0 ?

Total number of prefixes 2

PE1#sh bgp vpnv6 unicast all                        
BGP table version is 12, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf MSSK)
*> 2001:DB8::1/128  ::                       0         32768 ?
*>i2001:DB8::5/128  ::FFFF:4.4.4.4           0    100      0 ?
*> 2001:DB8:12::/64 ::                       0         32768 ?
*>i2001:DB8:45::/64 ::FFFF:4.4.4.4           0    100      0 ?

PE1#sh ipv6 route vrf MSSK
IPv6 Routing Table - MSSK - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, M - MIPv6, R - RIP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S   2001:DB8::1/128 [1/0]
     via 2001:DB8:12::1
B   2001:DB8::5/128 [200/0]
     via 4.4.4.4%Default-IP-Routing-Table, indirectly connected
C   2001:DB8:12::/64 [0/0]
     via FastEthernet1/0, directly connected
L   2001:DB8:12::2/128 [0/0]
     via FastEthernet1/0, receive
B   2001:DB8:45::/64 [200/0]
     via 4.4.4.4%Default-IP-Routing-Table, indirectly connected
L   FF00::/8 [0/0]
     via Null0, receive

PE1#ping vrf MSSK 2001:DB8::5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8::5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/16 ms

No comments: