Saturday, October 13, 2012

Xconnect




Issue

Configuring Xconnect to enable data transport between Ethernet and ATM


Configuration

TESTING1

interface ATM0
description *** TEC-TEC2 ATM 5/7 ***
no ip address
no atm ilmi-keepalive
dsl operating-mode ansi-dmt

interface ATM0.1 point-to-point
ip address 172.16.18.98 255.255.255.252
pvc 2/222
protocol ip 172.16.18.97 broadcast

interface ATM0.2 point-to-point
ip address 10.10.10.2 255.255.255.252
pvc 30/30
protocol ip 10.10.10.1 broadcast
!

TESTING2

interface FastEthernet0/0
no ip address
duplex full
speed 100
interface FastEthernet0/0.94
encapsulation dot1Q 94
ip address 10.10.10.2 255.255.255.252
!
interface FastEthernet0/0.99
encapsulation dot1Q 99
ip address 172.16.18.97 255.255.255.252

TEC-PE

interface GigabitEthernet2/1/0
mtu 1530
ip address 62.215.0.49 255.255.255.252
ip ospf network point-to-point
negotiation auto
mpls ip

interface ATM2/0/0
description *** ATM STM-1 Link To 6400-TEC ( ATM3/1/0 ) ***
no ip address
load-interval 30
no atm enable-ilmi-trap
no atm ilmi-keepalive
pvc 0/5 qsaal
!
pvc 0/16 ilmi
!

interface ATM2/0/0.2020 point-to-point
no atm enable-ilmi-trap
pvc 12/195 l2transport
encapsulation aal5snap
xconnect 62.215.0.222 133 pw-class inter-ether

TEST-PE

interface GigabitEthernet0/1
mtu 1530
ip address 62.215.0.50 255.255.255.252
ip ospf network point-to-point
media-type sfp
speed auto
duplex auto
negotiation auto
mpls ip

interface GigabitEthernet0/3
mtu 4470
no ip address
media-type rj45
speed auto
duplex full
negotiation auto

interface GigabitEthernet0/3.99
encapsulation dot1Q 99
xconnect 62.215.0.194 133 pw-class inter-ether

TEC-TEC2

interface ATM5/7
description *** DATA COM Test Port for Engineers ***
ip address 10.10.10.1 255.255.255.252
dsl subscriber Test.port
dsl profile C1024
no atm ilmi-keepalive
atm soft-vc 2 222 dest-address
47.0091.8100.0000.0005.5eb3.5701.4000.0c81.9000.00 12 195 rx-cttr 1 txcttr
1
pvc 30/30
protocol ip 10.10.10.2 broadcast
!
no snmp trap link-status
no snmp ifindex persist

Verification

TEC-TEST#sh xconnect all
Legend: XC ST=Xconnect State S1=Segment1 State S2=Segment2 State
UP=Up DN=Down AD=Admin Down IA=Inactive
SB=Standby RV=Recovering NH=No Hardware
XC ST Segment 1 S1 Segment 2
S2
------+---------------------------------+--+-----------------------------
----+--
UP ac Gi0/3.99:99(Eth VLAN) UP mpls 62.215.0.194:133
UP

TEC-TEST#sh xconnect peer 62.215.0.194 all detail

Legend: XC ST=Xconnect State S1=Segment1 State S2=Segment2 State
UP=Up DN=Down AD=Admin Down IA=Inactive
SB=Standby RV=Recovering NH=No Hardware
XC ST Segment 1 S1 Segment 2
S2
------+---------------------------------+--+-----------------------------
----+--
UP ac Gi0/3.99:99(Eth VLAN) UP mpls 62.215.0.194:133
UP
Interworking: ip Local VC label 276
Remote VC label 3090
pw-class: inter-ether

TEC-TEST#sh mpls l2transport binding 133
Destination Address: 62.215.0.194, VC ID: 133
Local Label: 276
Cbit: 1, VC Type: IP, GroupID: 0
MTU: 4470, Interface Desc: n/a
VCCV: CC Type: CW [1], RA [2]
CV Type: LSPV [2]
Remote Label: 3090
Cbit: 1, VC Type: IP, GroupID: 0
MTU: 4470, Interface Desc: n/a
VCCV: CC Type: RA [2]
CV Type: LSPV [2]

TEC-TEST#sh mpls l2transport vc 133 detail
Local interface: Gi0/3.99 up, line protocol up, Eth VLAN 99 up
MPLS VC type is Eth VLAN, interworking type is IP
Destination address: 62.215.0.194, VC ID: 133, VC status: up
Output interface: Gi0/1, imposed label stack {3090}
Preferred path: not configured
Default path: active
Next hop: 62.215.0.49
Create time: 03:55:11, last status change time: 03:55:11
Signaling protocol: LDP, peer 62.215.0.194:0 up
Targeted Hello: 62.215.0.222(LDP Id) -> 62.215.0.194
Status TLV support (local/remote) : enabled/supported
Label/status state machine : established, LruRru
Last local dataplane status rcvd: no fault
Last local SSS circuit status rcvd: no fault
Last local SSS circuit status sent: no fault
Last local LDP TLV status sent: no fault
Last remote LDP TLV status rcvd: no fault
MPLS VC labels: local 276, remote 3090
Group ID: local 0, remote 0
MTU: local 4470, remote 4470
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 1034, send 1034
byte totals: receive 1066540, send 1089288
packet drops: receive 0, seq error 0, send 0

TESTING2#ping 172.16.18.98 repeat 1000 size 1500
Type escape sequence to abort.
Sending 1000, 1500-byte ICMP Echos to 172.16.18.98, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (1000/1000), round-trip min/avg/max =
40/43/60 ms


No comments: